System Logs:Firewall Error



  • Hello,

    I just upgraded from 1.x to 2.2.3 and now I receive the following error under "Status: System logs: Firewall"

    Warning: getservbyport() expects parameter 1 to be long, string given in /etc/inc/filter_log.inc on line 273

    Does this indicate a bigger problem somewhere else?

    Here is a screen shot:



  • @trafficking:

    I just upgraded from 1.x to 2.2.3 and now I receive the following error under "Status: System logs: Firewall"

    A VERY OLD version, like 1.x CAN NOT be upgraded like that.
    Your config.xml contains to many 'settings' that are changed, not valid, or "being done otherwise".

    Its like upgrade from Windows 95 to Windows 8 : that just won't work well neither ….

    Result : your images explains it well  ....

    This is the read me first : https://doc.pfsense.org/index.php/Upgrade_Guide

    Just install from scratch, and setup by hand - using your backup up (you made a backup, upfront right ?) as a hand-guide. That ill do the trick.

    Btw: you just discovered why it isn't a good idea to wait that long to update ;)



  • The upgrade code from 1.x should all work. People did it in the past and everything there has been maintained.
    I suspect that there are old-format logs on the system still. And there will be other bits of JavaScript that might also be cached in your browser and you will need to make it load the new/latest.

    1. Refresh the whole page (ctrl-F5 or whatever makes your browser really load everything again) - as well as here in Firewall Logs, do it on other pages like Traffic Graph and anywhere else that seems to ave "wiz-bang" display capabilities that might be using JavaScript to make things on the page appear and disappear…

    2. Status->System Logs, Settings - Reset Log Files - that will make sure those are in current format to be interpreted correctly by current code.



  • @phil.davis:

    1. Status->System Logs, Settings - Reset Log Files - that will make sure those are in current format to be interpreted correctly by current code.

    This seems to have resolved the issue.  Thank you both for your help!


Log in to reply