No Web Gui on clean 2.2.3 install [SOLVED]



  • Think I killed an SSD on an install that was working fine on 2.2.2. Dropped a mechanical drive in, reinstalled latest 2.2.3, restored an old config and as the backup config was not the latest, manually re-did configuration (reinstalled packages, squid3, squidguard, sarg and nuts).

    As I was playing around getting a custom page to work in squidguard and playing around with selecting HTTP and HTTPS in the web gui settings I suddenly lost connection to the web gui. Tried rebooting, tried 'Restart webConfigurator', tried 'Restart PHP-HPM', tried dropping firewall with 'pfctl -d'. Nothing worked.

    I can ping the pfsense box.
    I can ssh into it.
    I did a 'netstat -la' and can't see anything that looks like the web configurator on any ports (definitely nothing on 80 and 443).
    I tried telnet to 80 and 443 with the firewall up and down and can't connect.
    I used another machine and port scanned the pfsense box and only got 3 ports open, 22 (that I can ssh onto fine), 53 for DNS (?) and 3128 for squid.

    Running 'ps -aux|  grep php'

    root    74426  0.0  0.3 224228  23180  -  Ss    4:53PM  0:00.01 php-fpm: master process (/usr/local/lib/php-fpm.conf) (php-fpm)
    root    74603  0.0  0.3 224228  23192  -  I    4:53PM  0:00.00 php-fpm: pool lighty (php-fpm)
    root    97067  0.0  0.0  18876  2372  1  S+    5:01PM  0:00.00 grep php

    The pfsense box and squid is working however and as mentioned I can ssh into it.

    However, I can't web administrate it - any ideas or help - or is it a reinstall again and restart?

    [SOLUTION?]
    I am not sure what caused it and its not completely solved. But I edited /conf/config.xml and changed the /webgui/protocol from https to http. Then deleted /tmp/config.cache. Then restarted the web gui in the shell. This allows me to at least start the web gui. Now to investigate what I changed trying to get a custom squidguard page.


Log in to reply