LAN - OPT1 bridge



  • Hi,

    I would like to have my LAN and OPT1 interfaces on the same subnet in order to use Airplay. I've been through various posts on the forum and tried multiple configurations without success, so your help would be much appreciated!

    I am currently running pfSense on VirtualBox (win8.1 host), with the following configuration:

    • WAN: 192.168.1.12/24 (bridged to physical ethernet) > DMZ on the router provided by my ISP
    • LAN: 10.0.0.1/24 (Host-only network) with DHCP activated from 10.0.0.5 to 10.0.0.99 > host + multiple VMs use this network
    • OPT1: 10.0.1.1/24 (bridged to physical ethernet) with DHCP activated from 10.0.1.5 to 10.0.1.99 > a wifi router in AP-mode with several connected devices use this network
      Everything works as expected, i.e. my host, vms, wifi devices can access the Internet behind pfSense and communicate with each other.

    My problem is that I cannot use Airplay between my host/vms and wifi devices because Airplay can only discover devices on the same subnet. So I would like to understand how to bridge LAN and OPT1 to have all devices on the 10.0.0.1 subnet.
    Could anyone share instructions to achieve this? My questions more specifically would be:

    • how to assign IP addresses between LAN, OPT1 and BRIDGE?
    • on which interface(s) to assign DHCP server(s)?
    • is any command required to force devices to take the changes into account?
    • what firewall rules to setup?

    Thanks in advance for your help!


  • LAYER 8 Global Moderator

    What is the point, why don't you just put all devices on lan??  You seem to have no use for opt1 if your just bridge them..



  • Thanks for the reply. That may be a simple solution indeed, how could I achieve it? Is it possible to assign LAN to the bridged ethernet port to which my wifi router is connected, and supply Internet to wireless devices, vms and host?
    Currently LAN is attached to the VirtualBox host-only network. Both host and vms get Internet from it (i.e. they're all behind pfSense). Other devices are connected to my wifi router, which is connected to the host via a physical ethernet port, which itself is bridged to pfSense.


  • LAYER 8 Global Moderator

    do you have a switch connected to your LAN?  Then just connect your AP or wifi router as AP (turn off its dhcp server and use a lan port on it) to connect to your lan switch..  Its really that simple.



  • Brilliant! It worked like a charm. For the record, here's what I did, based on your advice:

    • connect a physical bridge to the physical ethernet port of the host
    • connect the wireless AP to one of the LAN ports of the physical bridge
    • reinstall pfSense from scratch
    • assign the physical bridge to the LAN of pfSense (bridged mode in VirtualBox)
    • set pfSense LAN to 10.0.0.1/24 and activate DHCP
    • ensure Windows is using the physical port with the switch to connect to the Internet
    • use bridged connections to the physical ports for each vm
    • leave IP configuration of all devices to 'automatic'

    Thanks for help, your solution is very straightforward and saved me a lot of painful configurations :-)


Log in to reply