Web GUI configured to HTTPS 442, still listening on 80



  • Hi,

    I think I found a bug. I configured the Web GUI to listen to HTTPS port 442. But it is still listening on HTTP 80:

    : sockstat -l | grep light
    root    lighttpd  42802 5  tcp4  *:442                :
    root    lighttpd  42802 6  tcp6  *:442                :
    root    lighttpd  42802 7  tcp4  *:80                  :
    root    lighttpd  42802 8  tcp6  *:80                  :

    There is only one instance of lighttpd running

    : ps ax | grep light
      159  -  S      0:00.38 php-fpm: pool lighty (php-fpm)
    42802  -  S      0:06.20 /usr/local/sbin/lighttpd -f /var/etc/lighty-webConfig
    39724  0  S+      0:00.00 grep light

    I would like to use port 80 for something else. What might be the reason?

    Regards,

    DK


  • LAYER 8 Netgate

    See WebGUI Redirect in System > Advanced.

    ETA: Hmm.  Maybe not.  Doubt it's a bug though.  Maybe kick it with a reboot or a restart webconfigurator on the console.



  • The redirect listens on port 80 regardless of your HTTPS port. Just disable the redirect under System>Advanced.



  • @cmb:

    The redirect listens on port 80 regardless of your HTTPS port. Just disable the redirect under System>Advanced.

    That did it! Thank you!


Log in to reply