Squid 500 errors invalid requests



  • I tried to install squid on a multi-wan setup. Not that I'm expecting it to work with the multi-wan, I'm fine with the understanding that the squid will be limited to using the default gateway.

    I installed it and enable it for my LAN interface. BTW, I'm running a captive portal on another interface called LAN2(wifi for students).

    However as soon as I enable it everyone trying to navigate gets the dreaded 500 error.

    Do my rules play a part in this? I have rules on LAN allowing certain TCP ports to pass through the router, with all others being blocked.(no UDP here)

    I tried Squid both ways with and without my rules allowing port 80 to my Groups. I still get the same thing.

    Could someone help me out by listing somethings I might look at? Possible causes?



  • Are you blocking port 80 on the Lan2(wifi) interface?

    Also, if squid is on the default Lan interface you need a both in both interfaces that allows them to talk to each other or just the squid Lan address to port 80. These rules have to be above the rule that blocks port 80 (if any) on both interfaces.

    i.e.

    LAN                                                                        LAN2
    lan add – lan2 * (allow)                                  lan2 * --- 80 lan add (allow)
    lan2  *  -- 80  lan add (allow)                          lan add  --- 80  lan2 * (allow)                               
    lan *  ---  80 * (block)                                    lan2* --- 80 * (block)

    This is of course if you only want the two interfaces to communicate via port 80 only. Otherwise set for allow all.


Log in to reply