Pfsense 2.2.3 - Squidguard - не запускается



  • Чистая установка pfsense 2.2.3 ,затем Squid3, затем Squidguard + blacklists. Squidguard упрямо не запускается.
    На форуме так и не нашел внятного обьяснения , почему это происходит. Один советует не ставить squidGuard старый, типа он тянет с собой еще и Squid ,мол ставте новый. А какой новый , он в репе вообще один , нет там никакого Squidguard3 или Squidguard_Squid3 итп. В описании к squidGuard ясно написано Works with both Squid 2.x and Squid 3.x.  Так вот только DON`T WORK AT ALL. Что не так ? кто ставил отпишитесь пожалуста.



  • Какую версию Squidguard вы устанавливаете? Если старую, то она автоматом тянет 2-ой сквид. Соответственно, будут проблемы.



  • Если крашится сквид после перезапуска машины илди самого севриса тогда возможно вам сюда:

    https://doc.pfsense.org/index.php/SquidGuard_package

    Вот эта часть:

    Service does not Start

    If the squidGuard service will not start, there are a few possible explanations:

    On all versions of Squid, if only blacklists have been configured, then at startup some important files/directories may not be set properly. Add at least one Custom Target Category with a site to pass or block and use it along with the blacklist entries to work around the problem.
        On squid 3.x, the squidGuard service will only start when traffic requires it to run, so it can appear to be stopped even when working properly. Only worry about the service if it appears to not work, don't count on the service status alone.



  • Да так работает.Спасибо