USB WiFi adapter problem



  • Hello.

    I'm trying to configure Wifi on pfSense 2.2.3.
    I have added to loader.conf.local:

    if_run_load="YES"
    runfw_load="YES"

    Then I have USB WiFi adapter (HAMA rt2870) connected to pfSense.
    The USB WiFi adapter has been detected in the (assign) Interface.
    This is the output of the pfsense command # dmesg:

    $ dmesg
    Copyright (c) 1992-2014 The FreeBSD Project.
    Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    	The Regents of the University of California. All rights reserved.
    FreeBSD is a registered trademark of The FreeBSD Foundation.
    FreeBSD 10.1-RELEASE-p13 #0 c77d1b2(releng/10.1)-dirty: Tue Jun 23 17:09:45 CDT 2015
        root@pfs22-i386-builder:/usr/obj.i386/usr/pfSensesrc/src/sys/pfSense_wrap_vga.10.i386 i386
    FreeBSD clang version 3.4.1 (tags/RELEASE_34/dot1-final 208032) 20140512
    CPU: Intel(R) Atom(TM) CPU N270   @ 1.60GHz (1600.09-MHz 686-class CPU)
      Origin = "GenuineIntel"  Id = 0x106c2  Family = 0x6  Model = 0x1c  Stepping = 2
      Features=0xbfe9fbff <fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>Features2=0x40c39d <sse3,dtes64,mon,ds_cpl,est,tm2,ssse3,xtpr,pdcm,movbe>AMD Features=0x100000 <nx>AMD Features2=0x1 <lahf>TSC: P-state invariant, performance statistics
    real memory  = 1064173568 (1014 MB)
    avail memory = 1007480832 (960 MB)
    Event timer "LAPIC" quality 400
    ACPI APIC Table: <intelr awrdacpi="">
    FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
    FreeBSD/SMP: 1 package(s) x 1 core(s) x 2 HTT threads
     cpu0 (BSP): APIC ID:  0
     cpu1 (AP/HT): APIC ID:  1
    ioapic0: Changing APIC ID to 2
    ioapic0 <version 2.0=""> irqs 0-23 on motherboard
    ipw_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_bss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_bss_fw, 0xc08136b0, 0) error 1
    ipw_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_ibss: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_ibss_fw, 0xc0813760, 0) error 1
    ipw_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_ipw/.
    ipw_monitor: If you agree with the license, set legal.intel_ipw.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (ipw_monitor_fw, 0xc0813810, 0) error 1
    iwi_bss: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
    iwi_bss: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (iwi_bss_fw, 0xc083be40, 0) error 1
    iwi_ibss: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
    iwi_ibss: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (iwi_ibss_fw, 0xc083bef0, 0) error 1
    iwi_monitor: You need to read the LICENSE file in /usr/share/doc/legal/intel_iwi/.
    iwi_monitor: If you agree with the license, set legal.intel_iwi.license_ack=1 in /boot/loader.conf.
    module_register_init: MOD_LOAD (iwi_monitor_fw, 0xc083bfa0, 0) error 1
    wlan: mac acl policy registered
    kbd1 at kbdmux0
    random: <software, yarrow=""> initialized
    cryptosoft0: <software crypto=""> on motherboard
    padlock0: No ACE support.
    acpi0: <intelr awrdacpi=""> on motherboard
    acpi0: Power Button (fixed)
    acpi0: reservation of 0, a0000 (3) failed
    acpi0: reservation of 100000, 3f5e0000 (3) failed
    cpu0: <acpi cpu=""> on acpi0
    cpu1: <acpi cpu=""> on acpi0
    attimer0: <at timer=""> port 0x40-0x43 irq 0 on acpi0
    Timecounter "i8254" frequency 1193182 Hz quality 0
    Event timer "i8254" frequency 1193182 Hz quality 100
    atrtc0: <at realtime="" clock=""> port 0x70-0x73 irq 8 on acpi0
    Event timer "RTC" frequency 32768 Hz quality 0
    Timecounter "ACPI-fast" frequency 3579545 Hz quality 900
    acpi_timer0: <24-bit timer at 3.579545MHz> port 0x408-0x40b on acpi0
    acpi_button0: <power button=""> on acpi0
    acpi_button1: <sleep button=""> on acpi0
    pcib0: <acpi host-pci="" bridge=""> port 0xcf8-0xcff on acpi0
    pci0: <acpi pci="" bus=""> on pcib0
    vgapci0: <vga-compatible display=""> port 0xff00-0xff07 mem 0xfde80000-0xfdefffff,0xd0000000-0xdfffffff,0xfdf80000-0xfdfbffff irq 16 at device 2.0 on pci0
    agp0: <intel 945gme="" svga="" controller=""> on vgapci0
    agp0: aperture size is 256M, detected 7932k stolen memory
    vgapci0: Boot video device
    vgapci1: <vga-compatible display=""> mem 0xfdf00000-0xfdf7ffff at device 2.1 on pci0
    hdac0: <intel 82801g="" hda="" controller=""> mem 0xfdff8000-0xfdffbfff irq 16 at device 27.0 on pci0
    pcib1: <acpi pci-pci="" bridge=""> irq 16 at device 28.0 on pci0
    pci1: <acpi pci="" bus=""> on pcib1
    re0: <realtek 8111="" 8168="" b="" c="" cp="" d="" dp="" e="" f="" g="" pcie="" gigabit="" ethernet=""> port 0xbe00-0xbeff mem 0xfd7ff000-0xfd7fffff,0xfd4f0000-0xfd4fffff irq 16 at device 0.0 on pci1
    re0: Using 1 MSI-X message
    re0: Chip rev. 0x3c000000
    re0: MAC rev. 0x00400000
    miibus0: <mii bus=""> on re0
    rgephy0: <rtl8169s 8211="" 8110s="" 1000base-t="" media="" interface=""> PHY 1 on miibus0
    rgephy0:  none, 10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, auto-flow
    pcib2: <acpi pci-pci="" bridge=""> irq 17 at device 28.1 on pci0
    pci2: <acpi pci="" bus=""> on pcib2
    re1: <realtek 8111="" 8168="" b="" c="" cp="" d="" dp="" e="" f="" g="" pcie="" gigabit="" ethernet=""> port 0xae00-0xaeff mem 0xfddff000-0xfddfffff,0xfdcf0000-0xfdcfffff irq 17 at device 0.0 on pci2
    re1: Using 1 MSI-X message
    re1: Chip rev. 0x3c000000
    re1: MAC rev. 0x00400000
    miibus1: <mii bus=""> on re1
    rgephy1: <rtl8169s 8211="" 8110s="" 1000base-t="" media="" interface=""> PHY 1 on miibus1
    rgephy1:  none, 10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, auto-flow
    pcib3: <acpi pci-pci="" bridge=""> irq 18 at device 28.2 on pci0
    pci3: <acpi pci="" bus=""> on pcib3
    re2: <realtek 8111="" 8168="" b="" c="" cp="" d="" dp="" e="" f="" g="" pcie="" gigabit="" ethernet=""> port 0xee00-0xeeff mem 0xfdbff000-0xfdbfffff,0xfdaf0000-0xfdafffff irq 18 at device 0.0 on pci3
    re2: Using 1 MSI-X message
    re2: Chip rev. 0x3c000000
    re2: MAC rev. 0x00400000
    miibus2: <mii bus=""> on re2
    rgephy2: <rtl8169s 8211="" 8110s="" 1000base-t="" media="" interface=""> PHY 1 on miibus2
    rgephy2:  none, 10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, auto-flow
    pcib4: <acpi pci-pci="" bridge=""> irq 19 at device 28.3 on pci0
    pci4: <acpi pci="" bus=""> on pcib4
    re3: <realtek 8111="" 8168="" b="" c="" cp="" d="" dp="" e="" f="" g="" pcie="" gigabit="" ethernet=""> port 0xde00-0xdeff mem 0xfd9ff000-0xfd9fffff,0xfd8f0000-0xfd8fffff irq 19 at device 0.0 on pci4
    re3: Using 1 MSI-X message
    re3: Chip rev. 0x3c000000
    re3: MAC rev. 0x00400000
    miibus3: <mii bus=""> on re3
    rgephy3: <rtl8169s 8211="" 8110s="" 1000base-t="" media="" interface=""> PHY 1 on miibus3
    rgephy3:  none, 10baseT, 10baseT-FDX, 10baseT-FDX-flow, 100baseTX, 100baseTX-FDX, 100baseTX-FDX-flow, 1000baseT, 1000baseT-master, 1000baseT-FDX, 1000baseT-FDX-master, 1000baseT-FDX-flow, 1000baseT-FDX-flow-master, auto, auto-flow
    uhci0: <intel 82801g="" (ich7)="" usb="" controller="" usb-a=""> port 0xfe00-0xfe1f irq 23 at device 29.0 on pci0
    usbus0 on uhci0
    uhci1: <intel 82801g="" (ich7)="" usb="" controller="" usb-b=""> port 0xfd00-0xfd1f irq 19 at device 29.1 on pci0
    usbus1 on uhci1
    uhci2: <intel 82801g="" (ich7)="" usb="" controller="" usb-c=""> port 0xfc00-0xfc1f irq 18 at device 29.2 on pci0
    usbus2 on uhci2
    uhci3: <intel 82801g="" (ich7)="" usb="" controller="" usb-d=""> port 0xfb00-0xfb1f irq 16 at device 29.3 on pci0
    usbus3 on uhci3
    ehci0: <intel 82801gb="" r="" (ich7)="" usb="" 2.0="" controller=""> mem 0xfdfff000-0xfdfff3ff irq 23 at device 29.7 on pci0
    usbus4: EHCI version 1.0
    usbus4 on ehci0
    pcib5: <acpi pci-pci="" bridge=""> at device 30.0 on pci0
    pci5: <acpi pci="" bus=""> on pcib5
    isab0: <pci-isa bridge=""> at device 31.0 on pci0
    isa0: <isa bus=""> on isab0
    atapci0: <intel ich7="" udma100="" controller=""> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xfa00-0xfa0f at device 31.1 on pci0
    ata0: <ata channel=""> at channel 0 on atapci0
    atapci1: <intel ich7m="" sata150="" controller=""> port 0xf900-0xf907,0xf800-0xf803,0xf700-0xf707,0xf600-0xf603,0xf500-0xf50f mem 0xfdffe000-0xfdffe3ff irq 19 at device 31.2 on pci0
    ata2: <ata channel=""> at channel 0 on atapci1
    ata3: <ata channel=""> at channel 1 on atapci1
    acpi_tz0: <thermal zone=""> on acpi0
    uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
    uart1: <16550 or compatible> port 0x2f8-0x2ff irq 3 on acpi0
    pmtimer0 on isa0
    orm0: <isa option="" rom=""> at iomem 0xef000-0xeffff pnpid ORM0000 on isa0
    sc0: <system console=""> at flags 0x100 on isa0
    sc0: VGA <16 virtual consoles, flags=0x300>
    vga0: <generic isa="" vga=""> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
    atkbdc0: <keyboard controller="" (i8042)=""> at port 0x60,0x64 on isa0
    atkbd0: <at keyboard=""> irq 1 on atkbdc0
    kbd0 at atkbd0
    atkbd0: [GIANT-LOCKED]
    ppc0: parallel port not found.
    est0: <enhanced speedstep="" frequency="" control=""> on cpu0
    p4tcc0: <cpu frequency="" thermal="" control=""> on cpu0
    est1: <enhanced speedstep="" frequency="" control=""> on cpu1
    p4tcc1: <cpu frequency="" thermal="" control=""> on cpu1
    Timecounters tick every 1.000 msec
    IPsec: Initialized Security Association Processing.
    random: unblocking device.
    usbus0: 12Mbps Full Speed USB v1.0
    usbus1: 12Mbps Full Speed USB v1.0
    usbus2: 12Mbps Full Speed USB v1.0
    usbus3: 12Mbps Full Speed USB v1.0
    usbus4: 480Mbps High Speed USB v2.0
    ugen0.1: <intel> at usbus0
    uhub0: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr=""> on usbus0
    ugen1.1: <intel> at usbus1
    uhub1: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr=""> on usbus1
    ugen3.1: <intel> at usbus3
    uhub2: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr=""> on usbus3
    ugen2.1: <intel> at usbus2
    uhub3: <intel 1="" 9="" uhci="" root="" hub,="" class="" 0,="" rev="" 1.00="" 1.00,="" addr=""> on usbus2
    ugen4.1: <intel> at usbus4
    uhub4: <intel 1="" 9="" ehci="" root="" hub,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr=""> on usbus4
    uhub0: 2 ports with 2 removable, self powered
    uhub1: 2 ports with 2 removable, self powered
    uhub2: 2 ports with 2 removable, self powered
    uhub3: 2 ports with 2 removable, self powered
    SMP: AP CPU #1 Launched!
    Timecounter "TSC" frequency 1600090032 Hz quality 1000
    Root mount waiting for: usbus4
    uhub4: 8 ports with 8 removable, self powered
    Root mount waiting for: usbus4
    ugen4.2: <vendor 0x05e3=""> at usbus4
    uhub5: <vendor 2="" 9="" 0x05e3="" usb2.0="" hub,="" class="" 0,="" rev="" 2.00="" 77.64,="" addr=""> on usbus4
    Root mount waiting for: usbus4
    uhub5: 4 ports with 4 removable, self powered
    ugen4.3: <generic> at usbus4
    umass0: <generic 0="" 3="" mass="" storage="" device,="" class="" 0,="" rev="" 2.00="" 1.00,="" addr=""> on usbus4
    Root mount waiting for: usbus4
    ugen4.4: <vendor 0x04f3=""> at usbus4
    ukbd0: <vendor 0="" 4="" 0x04f3="" product="" 0x0103,="" class="" 0,="" rev="" 2.00="" 1.07,="" addr=""> on usbus4
    kbd2 at ukbd0
    uhid0: <vendor 0="" 4="" 0x04f3="" product="" 0x0103,="" class="" 0,="" rev="" 2.00="" 1.07,="" addr=""> on usbus4
    da0 at umass-sim0 bus 0 scbus3 target 0 lun 0
    da0: <multiple card ="" reader="" 1.00=""> Removable Direct Access SCSI-0 device 
    da0: Serial Number 058F63666433
    da0: 40.000MB/s transfers
    da0: 7580MB (15523840 512 byte sectors: 255H 63S/T 966C)
    da0: quirks=0x2 <no_6_byte>Trying to mount root from ufs:/dev/ufs/pfsense1 [ro,sync,noatime]...
    WARNING: / was not properly dismounted
    pflog0: promiscuous mode enabled
    re0: link state changed to DOWN
    re0: link state changed to UP
    ng0: changing name to 'pppoe0'
    re0: link state changed to DOWN
    re0: link state changed to UP
    re3: link state changed to UP
    ng_pppoe[13]: no matching session
    ng_pppoe[13]: no matching session
    ng_pppoe[13]: no matching session
    ng_pppoe[13]: no matching session
    ng0: changing name to 'pppoe0'
    ugen4.5: <ralink> at usbus4
    run0: <1.0> on usbus4
    run0: MAC/BBP RT2872 (rev 0x0202), RF RT2820 (MIMO 2T2R), address 90:2a:4c:14:33:a3</ralink></no_6_byte></multiple></vendor></vendor></vendor></generic></generic></vendor></vendor></intel></intel></intel></intel></intel></intel></intel></intel></intel></intel></cpu></enhanced></cpu></enhanced></at></keyboard></generic></system></isa></thermal></ata></ata></intel></ata></intel></isa></pci-isa></acpi></acpi></intel></intel></intel></intel></intel></rtl8169s></mii></realtek></acpi></acpi></rtl8169s></mii></realtek></acpi></acpi></rtl8169s></mii></realtek></acpi></acpi></rtl8169s></mii></realtek></acpi></acpi></intel></vga-compatible></intel></vga-compatible></acpi></acpi></sleep></power></at></at></acpi></acpi></intelr></software></software,></version></intelr></lahf></nx></sse3,dtes64,mon,ds_cpl,est,tm2,ssse3,xtpr,pdcm,movbe></fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,htt,tm,pbe>
    

    When I try to configure WiFI and to save settings, pfsense freezes and can not reboot.
    Has anyone any ideas on how to make it work?



  • If you look through recent posts in this section you will notice problems with RALink's. I tested a RALink module and it worked fine but i notice USB dongles seem troubled. Also no need to add anything to pfSense loader. The RALink driver should catch those automatically. Is your chipset not supported? Mine worked seamlessly just as the Atheros modules do. Not quite as fast…



  • The Chipset (RT2870 https://www.freebsd.org/cgi/man.cgi?query=run%284%29)
    is supported and it worked with the pfSense version 2.1.5.
    I have now the kernel runfw.ko and if_run.ko from "/boot/kernel/" and the entries
    from loader.conf.local removed and tried it again.

    I have the same problem after reboot. Do I need another kernel?


  • Banned



  • I have bought Compex WLE200NX mini-PCIe card (Atheros AR9280) and I try it to activate on 3I270D embeded PC, but pfsense will not detect the WiFi card.
    Which kernel drivers do I need?


  • Rebel Alliance Developer Netgate

    The drivers for that card are already present.



  • My first though was maybe it is a WWAN slot but i see the BRIK3i270 has a regular slot. Do you see a ath0 in your boot logs?



  • Well my first inkling was right:

    http://www.lex.com.tw/products/BRIK2.5-3I270D.html

    USB slot for WWAN