Problem with Squid3 and Squidguard.



  • hello there;
    I am a newbie regarding pfsense setup. and I'm a little tired of searching the google about my issue with Pfsense setup partaking to Squid3 and Squidguard when I both install them successfully and going to restart. upon success boot of the pfsense when I look into service status they booth are not running or stop. this will only happen when squidguard are installed but without the squidguard the squid3 aka proxy server is running smoothly.

    my Hardware setup is Core 2 Duo E6600 3.0ghz
    RAM: 4gb DDR2
    LAN Connection: re0 witch is connected to built-in LAN in the motherboard
    WAN Connection: me0 Intel Pro Dual Port 1000xt
    Hard Disk: 250GB

    2.2.4-RELEASE (amd64)
    built on Sat Jul 25 19:57:37 CDT 2015

    package installed only is
    squid3
    squidguard

    when both of that package is installed I have no way of running them successful otherwise uninstall the squidguard and the squid3 is will work properly.

    i have also follow this step but not successful posted by Tikimotel
    https://forum.pfsense.org/index.php?topic=73640.0

    thanks in advance for those who will help and the community as well.

    best regards from Philippines
    Argie Santos



  • Hello,

    Have you created a Target Category: if you don't create a Target Category (even one that you don't specify any actions for) squidGuard will stop working and often take down squid with it.

    This problem is covered in the documentation for the squidGuard package here https://doc.pfsense.org/index.php/SquidGuard_package

    I hope this helps, but let me know if this doesn't work :)



  • Plus, unlike Squid, squidGuard isn't a real service.  It's a helper app that gets called on-demand by squid for every URL being processed.



  • Hi, check my solution on this topic:
    https://208.123.73.68/index.php?topic=97211.0



  • @max2040uk:

    Hello,

    Have you created a Target Category: if you don't create a Target Category (even one that you don't specify any actions for) squidGuard will stop working and often take down squid with it.

    This problem is covered in the documentation for the squidGuard package here https://doc.pfsense.org/index.php/SquidGuard_package

    I hope this helps, but let me know if this doesn't work :)

    I agree this solution, its works!  ;D



  • thank you guys for your suggestion and comments, and sorry for the late feedback due to a reason I temporarily disable of using both squid3 and squidguard at the same time. I've made some experiment and follow some of your suggestion. but unfortunately it has an abnormal functionality sometime it works sometimes it won't so I decided to stop for awhile. but anyway and again thank you guys for the help.

    best regards

    Argie Santos
    from Philippines.