SquidGuard service state: STOPPED



  • Merhaba aktif kullanmış olduğumuz pfsense upgrade yaptıktan sonra squid servisi stopped oldu sistem loğları aşşağıdadir ilginiz için şimdiden tesekkurler

    php-fpm[41892]: /rc.start_packages: The command '/usr/pbi/squid-i386/sbin/squid -k reconfigure' returned exit code '1', the output was '2015/07/30 14:16:10| parseConfigFile: squid.conf:68 unrecognized: 'url_rewrite_bypass' squid: ERROR: Could not send signal 1 to process 84565: (3) No such process'



  • Target categories de herhangi bir tanımlama var mı ? Yok ise yapıp tekrar dener misiniz ?



  • Services–------>Proxyfilter----->Proxy filter SquidGuard: Blacklist page  bölümünde bulunan  blacklist update kısmına http://www.shallalist.de/Downloads/shallalist.tar.gz yazıp download tıklarmısın?

    Tıkadıktan sonra target list gelecektir. Ondan sonra tekarrdan SquidGuard service state: STARTED yapmayı deneyin. Eğer olmassa pfsenseyi restart edip tekrardan restart edin servisi.

    İnşaallah düzelir.
    Ben genelde bu şekilde yapınca düzeliyor.

    Teşekkürler.



  • Squid ile Squidguard şuan birlikte çalışmıyor. hanifimehmet in dediğini yapsanızda pfsensenin her açılışında işlemi tekrarlamanız gerekiyor.



  • Ben son sürümü kullanıyorum. Stabil çalışıyor ve her türlü filtrelemeyi de aktif yapıyor. Bence ayarlarınız ile ilgili bir problem var diye düşünüyorum. Geçmişteki log'lar da buna sebeb olabiliyor.

    mv /var/squid/cache /var/squid/cache.old
    squid -z
    rm -rf /var/squid/cache.old
    

    Cache'i silip tekrar denersen. Belki bir çözüm yolu olabilir.



  • @lord2oo0:

    Ben son sürümü kullanıyorum. Stabil çalışıyor ve her türlü filtrelemeyi de aktif yapıyor. Bence ayarlarınız ile ilgili bir problem var diye düşünüyorum. Geçmişteki log'lar da buna sebeb olabiliyor.

    mv /var/squid/cache /var/squid/cache.old
    squid -z
    rm -rf /var/squid/cache.old
    

    Cache'i silip tekrar denersen. Belki bir çözüm yolu olabilir.

    Pfsense sürümünüz nedir
    Squid ve SquidGuard sürümünüz nedir

    Pfsense 2.0.3 sürüm squid ve squidguard son sürümlerde sorun bulunmakta. Sıfır kurulumdada aynı sorunu yaşıyoruz. Size zahmet yazmış olduğum sürüm bilgilerini yazabilecekmisiniz. Bende ona göre kurulum yapayım yeniden.



  • Bende aynı sorunu yaşıyorum yaptığım araştırmalarda squidguard a gelen yeni güncelleme sonrasında bu sorun yaşanmaktaymış. 2 hafta önce yapılandırdığım 2.2.4 makinem sorunsuz çalışıyor ama dün kurduğum makine sorunlu restart olduktan sonra bir türlü squidguard start olmuyor.



  • bu sorunun sebebi, büyük ihtimalle squidguard'ın squid'deki custom options'a yazdığı opsyionlardaki yolun hatalı olması.
    ama çözümü bilmiyorum.



  • @AYKUTYILDIZ:

    Bende aynı sorunu yaşıyorum yaptığım araştırmalarda squidguard a gelen yeni güncelleme sonrasında bu sorun yaşanmaktaymış. 2 hafta önce yapılandırdığım 2.2.4 makinem sorunsuz çalışıyor ama dün kurduğum makine sorunlu restart olduktan sonra bir türlü squidguard start olmuyor.

    Bende 2 3 hafta önce 2.0.3 kurdum ancak squidguard çalışmıyor. Custom Options ile iligli sorun ama baya bir saçmalık oldu bu. Kiminde çalışıyor kiminde çalışmıyor. En son çalışmayan daki sürüm nedir.



  • @Liderweb:

    @AYKUTYILDIZ:

    Bende aynı sorunu yaşıyorum yaptığım araştırmalarda squidguard a gelen yeni güncelleme sonrasında bu sorun yaşanmaktaymış. 2 hafta önce yapılandırdığım 2.2.4 makinem sorunsuz çalışıyor ama dün kurduğum makine sorunlu restart olduktan sonra bir türlü squidguard start olmuyor.

    Bende 2 3 hafta önce 2.0.3 kurdum ancak squidguard çalışmıyor. Custom Options ile iligli sorun ama baya bir saçmalık oldu bu. Kiminde çalışıyor kiminde çalışmıyor. En son çalışmayan daki sürüm nedir.

    üşenmeden denedim 2.2.3 ve 2.2.2 bu iki sürümüde denedim squid ve squidguard ilk ayarlar yapıldığında çalışıyor makineyi restart edince servisler stop olarak açılıyor



  • Sürümler bunlar.



  • @lord2oo0:

    Sürümler bunlar.

    Squid 4.3.6 yı nerden buldunuz? Şuan 4.3.4 var. Squid sürüm güncellemesi gelmiş sorunsuz çalışıyor ise. Ancak bizde gözükmüyor bu sürüm.



  • @Liderweb:

    @lord2oo0:

    Sürümler bunlar.

    Squid 4.3.6 yı nerden buldunuz? Şuan 4.3.4 var. Squid sürüm güncellemesi gelmiş sorunsuz çalışıyor ise. Ancak bizde gözükmüyor bu sürüm.

    ben pfsense 2.0.3 kullanıyorum
    bende de şu an güncel squid sürümü 2.7.9 pkg v 4.3.4 görünüyor.



  • Son sürümü download edip kurdum. Var olan Squid sürümünüde otomatik kurdum.
    Sistem 64 bit bununla mı alakalı yoksa 2.2.4 ile mi alakalı onu bilemeyecem. Ama elimdeki versiyon bu?



  • merhaba problemin çözümünü bulan varmı acaba? aynı sorunu başka pfsense cihazındada yaşıyorum.



  • Selam,

    hanifimehmet dediği gibi blacklist güncelledikten sonra servis start oluyor. Ekran görüntüsündeki gibi target categories herhangi bir site eklersen her seferinde blacklist güncellemen gerekmiyor. Ben bu şekilde kullanıyorum. Test amaçlı 2 pfsense daha kurdum aynı şekilde sorunu çözdüm.



  • @tosman61:

    merhaba problemin çözümünü bulan varmı acaba? aynı sorunu başka pfsense cihazındada yaşıyorum.

    problemin kesin çözümü bir süre squidguarda hiç bulaşmamak. Zaten squidin de son sürümü sorunlu geldi. Aktif olmuyor. Squid3 kurulu bende sadece yetiyor şimdilik. Squidden daha salıklı ve güzel bir sistemi var squid3 ünde. SquidGuard düzelirse kurarız yeniden.



  • @den1905:

    Selam,

    hanifimehmet dediği gibi blacklist güncelledikten sonra servis start oluyor. Ekran görüntüsündeki gibi target categories herhangi bir site eklersen her seferinde blacklist güncellemen gerekmiyor. Ben bu şekilde kullanıyorum. Test amaçlı 2 pfsense daha kurdum aynı şekilde sorunu çözdüm.

    Bende de bu şekilde çözüldü.(2.2.4-RELEASE (amd64))
    TEŞEKKÜRLER



  • merhaba arkadaşlar pf eski versiyon olarak kurunca squid ve squard otamatik olarak güncel versiyonu cekiyor ve hiç  bir şekilde servis online olmuyor online görünse de arka planda çalışmıyor 2.1.5 64 bit versiyonu ile sorunu çözdüm şuan sorunsuz kullanıyorum



  • arkadaşlar 1 hafta uğraştım son sürüm pfsens de squid ve squidguard ı aktif edemedim.Target categories de elle ayar yapınca gidiyor yapmazsam calışıyor sorun yok. arkadaşta belki eski bir yedekten alıyorsa ayarlarını onunla alakalı olabilir. Ben 2.1.5 sürümü kurdum sorunum çözüldü.


Log in to reply