All HTTP redirected to HTTPS after 2.2.4 upgrade



  • I use pfSense + Squid as reverse proxy to map one external IP (several subdomains) to several internal servers.
    Some are HTTP, some are HTTPS.
    It worked well until today.
    For now, all attempt to access HTTP sites automatically redirect to HTTPS. Can't figure why…

    Both Squid reverse HTTP and HTTPS are enabled.
    Some servers are configured on port 80 / protocol HTTP
    Others on port 443 / protocol HTTPS

    All servers have apache interface, listening only port 80 or port 443.

    Did I miss an option somewhere ?



  • Greatings,

    Any clue about what to check or how to diagnose this kind of behavior ?

    Best regards.



  • Finally, achieved to narrow my investigations:

    Got this page displaying during redirection:
    HTTP/1.1 301 Moved Permanently
    Location: https://www.xxxx.yyy/
    Content-Length: 0
    Date: Tue, 04 Aug 2015 14:07:15 GMT
    Server: lighttpd/1.4.35

    And found this in pfSense lighttpd config file:
    $SERVER["socket"] == ":80" {
    $HTTP["host"] =~ "(.)" {
    url.redirect = ( "^/(.
    )" => "https://%1/$1" )
    }
    }
    $SERVER["socket"] == "[::]:80" {
    $HTTP["host"] =~ "(.)" {
    url.redirect = ( "^/(.
    )" => "https://%1/$1" )
    }
    }

    But I don't want to have all the HTTP traffic redirected to HTTPS!
    I didn't find where this can be change in webConfigurator. Don't see any such rule in firewall or reverse proxy.
    Many thanks for any advice…


  • Banned

    @jbcrouigneau:

    But I don't want to have all the HTTP traffic redirected to HTTPS!

    So disable it? SIGDUH!



  • It was there !
    Many thanks !