[résolu] pppoe sur un vdsl et modem tp-link wd9980 en bridge



  • Bonjour à tous,
    me voila devant un soucis de connexion pppoe avec un modem tp-link w9980 en bridge.

    Je gère plusieurs sites avec pfsense virtualisé avec proxmox. Cartes réseaux virtuelles e1000.

    Des sites avec un modem adsl, linksys ou zyxel, en mode bridge sur un lien ADSL Orange.
    pfsense fait la connexion en PPPoE : ça fonctionne sans problème.

    Sur un site, j'ai un lien fibre Orange.
    Là encore, ça fonctionne en branchant l'ONT sur la pate wan du pfsense.
    J'ai mis le VLAN 835 dans promox, sur la carte virtuelle correspondante. Ainsi, pas besoin de configurer le vlan dans pfsense.

    Mais voila, je bloque pour une migration de l'adsl en vdsl sur un site.

    Je souhaiterai faire la connection depuis pfsense en pppoe pour obtenir l'adresse ip publique dessus. Utile pour l'ipsec.
    J'ai pris un modem vdsl tp-link wd9980 pour la possibilité du mode bridge.

    1er test :
    configuration de la connexion PPPoE depuis le modem : ok. (other, vdsl, Vlan 835). Le modem se connecte et récupère l'IP.

    2e test :
    Modem en mode bridge. Vlan 835.
    Pfsense : pppoe configuré avec les bons identifiants.
    le vlan 835 est sur la pate proxmox, comme pour mon site avec la fibre.
    pfsense n'arrive pas à se connecter.

    Essais effectués :

    • vlan laissé sur le modem. Pas sur proxmox.
    • l'inverse.
    • vlan configuré dans pfsense et non proxmox.
    • vlan nulle part

    rien. pfsense ne se connecte pas.

    j'ai refais mes tests avec pfsense à jour : v2.2.4. il n'y arrive pas non plus.

    j'ai fait un tcpdump -i em1 -e -s 0 -w /root/pppoe.pcap :
    pfsense lance le pppoe en broadcast, je n'ai rien en retour.
    pourtant, le câble est bien branché des 2 côtés : modem comme pfsense (vérifié avec un ethtool em1 câble branché et débranché pour voir la détection du branchement du câble).

    Je sèche… une idée ?
    merci  :)

    edit :
    peut être le LAN du modem qui n'a pas de VLAN configurable, et le mode bridge qui ne fait pas suivre ?



  • Je ne suis pas certain du tout que pfsense soit réellement concerné tant cette configuration est peu orthodoxe (pour ne pas dire malsaine).



  • ah mais je ne soupçonnai pas notre ami pfSense, je recherchais une piste  :D
    Et puis, il se fait souvent virtualisé en plus. Pas de soucis de fonctionnement  ;)

    J'ai trouvé :
    pour prendre en compte une modification sur le modem du WAN (connection PPPoE, bridge, avec ou sans VLAN…), il faut le redémarrer pour que les modifications soient prisent en compte.

    Je ne le redémarrais pas après chaque modif. Ce n'est pas indiqué.

    Du coup, sur le modem :
    VDSL
    pas de VLAN. ça ne fonctionne pas en indiquant 835. Normal, le VLAN 835 est fait par l'équipement qui se connecte. Notre ami en l’occurrence.
    mode bridge.
    et reboot  ;D ;D

    pfSense fait la connexion comme un grand.

    le firmware est celui du mois de mai 2015. Peut être plus besoin d'un reboot avec d'autres mises à jour ?

    Purée, ça fait un moment que je m'arrache les cheveux à cause d'un reboot nécessaire non signalé !



  • Dès qu'il y a des modifications de vlan, d'affectation de carte l'expérience m'a montré qu'il fallait relancer Pfsense en effet.



  • <mode a_coté="">Pourquoi utiliser ce type de matériel (avec partie Wifi) ?

    Pour éviter box ou modem FAI, j'utilise usuellement des modem ADSL classiques comme tplink td8616 ou td 8816 ou dlink dsl-320b.
    J'évite d'acheter un matériel avec une partie inutile comme le wifi.</mode>



  • @ccnet:

    Dès qu'il y a des modifications de vlan, d'affectation de carte l'expérience m'a montré qu'il fallait relancer Pfsense en effet.

    Je ne l'ai pas précisé car à la lecture ça me semblait évident  :-[, c'est le modem TP LINK qu'il faut redémarrer.
    Pas besoin pour pfSense.

    [quote author=jdh link=topic=97593.msg543700#msg543700 date=1438781463]
    <mode a_coté="">Pourquoi utiliser ce type de matériel (avec partie Wifi) ?

    Pour éviter box ou modem FAI, j'utilise usuellement des modem ADSL classiques comme tplink td8616 ou td 8816 ou dlink dsl-320b.
    J'évite d'acheter un matériel avec une partie inutile comme le wifi.</mode>

    Car j'ai migré en VDSL donc ces modems de techno ADSL me sont inutiles  ;)
    Pas de modem VDSL non routeur, à ma connaissance.
    Je n'ai pas fouillé plus que LDLC ou materiel.net.
    Je désactive le wifi et ça me va.

    Un peu hors sujet mais si ça intéresse de futurs lecteurs, je trouve l'interface très bien :
    légère, pleins d'options. On peut avoir un aperçu depuis le site TP-Link, rubrique émulateur.

    A priori stable. La connexion est meilleure que la livebox (bon ça, il n'y a pas de mal  8))