OpenVPN Using FreeRadius2 for Auth



  • Just upgraded my pfsense firewall to ver 2.2.4. We are using OpenVPN for clients working in remote locations to be able to access out network. Using a 16 Digit "Secret" key generated using an application on a phone in conjunction with a pin the user has chosen. The Client accounts are input into FreeRadius with the key and the pin the client provides, and that has worked until we updated our firewall to 2.2.4, is there any suggestions on how to get it working again. All the clients are unable to access it.

    The list of things I have already tried:
    1. Had the client verify the key is correct on the application and that they are still using the correct pin.
          –> This of-course is not the issue seeing as it's not just a single client but all, but still had to confirm.
    2. Checked the epoch time of the server vs the otp time on the application and made sure they matched.
          --> Any clients that need a time offset have the correct offset and the clients that don't have the offset match the epoch on the server.
    3. Reinstalled the FreeRadius and OpenVPN applications on the firewall.

    None of the above has worked.

    Any suggestions.