No puedo ver peliculas online con squid3 y squidguard



  • Buenas tardes soy de argentina , acudo a la ayuda del foro ya que unos dias que tengo un problema y no logro solucionarlo, El problema es el siguiente: después de instalar de cero el pfsense con los paquetes squid 3 y squidguard, no logro poder ver peliculas online, en los reproductores de las paginas donde estan alojadas las películas me aparece un cartel que no se pudo conectar con el servidor rtmpt, estoy seguro que es problema del proxy ya que cuando no paso por squid logro ver las peliculas perfectamente, antes si podia ver las peliculas pero al instalar de cero la ultima versión de pfsense con los paquetes mencionados ya no puedo ver dichas películas si estoy bajo el squid, le adjunto unas capturas asi ven mejor de que estoy hablando , la primer foto es lo que me aparece al  querer ver la película a través de squid .
    la segunda foto son los paquetes que tengo instalados.
    La versión de pfsense que estoy usando es 2.2.4-RELEASE  (i386)
    al squid lo estoy usando en modo transparente sin intersepcion https, osea solo trabaja bajo http.
    Desde ya agradezco la ayuda del post y si precisan mas datos digamne
    slds
    ![con squid.jpg](/public/imported_attachments/1/con squid.jpg)
    ![con squid.jpg_thumb](/public/imported_attachments/1/con squid.jpg_thumb)



  • Deten el servicio de SquidGuard y nos dices si te dá el mismo fallo.



  • gracias por contestar, acabo de detener el squidguard como me indico y me aparece el mismo fallo,

    ![sin squid.jpg](/public/imported_attachments/1/sin squid.jpg)
    ![sin squid.jpg_thumb](/public/imported_attachments/1/sin squid.jpg_thumb)
    ![no funciona sin squidguard tampoco.jpg](/public/imported_attachments/1/no funciona sin squidguard tampoco.jpg)
    ![no funciona sin squidguard tampoco.jpg_thumb](/public/imported_attachments/1/no funciona sin squidguard tampoco.jpg_thumb)



  • Agrega el puerto que utiliza el rtmtp (1935?) a safe ports y ssl ports

    Sigo buscando algo que te pueda ayudar, como alguna excepción o expresión regular.

    Abrazo



  • Gracias por ayudarme, pero habilite el puerto 1935 como me indico y sigo teniendo el mismo problema, lo raro es que si navego sin el squid puedo ver las películas perfectamente, realmente no se que puede ser del squid que me bloquea , les adjunto las capturas con dicho puerto habilitado como me indicaron

    ![puerto 1935 habilitado en proxy.jpg](/public/imported_attachments/1/puerto 1935 habilitado en proxy.jpg)
    ![puerto 1935 habilitado en proxy.jpg_thumb](/public/imported_attachments/1/puerto 1935 habilitado en proxy.jpg_thumb)
    ![mismo error con puerto 1935 habilitado.jpg](/public/imported_attachments/1/mismo error con puerto 1935 habilitado.jpg)
    ![mismo error con puerto 1935 habilitado.jpg_thumb](/public/imported_attachments/1/mismo error con puerto 1935 habilitado.jpg_thumb)



  • Partamos de la base que el squid gestiona peticiones http y https.

    rtmtp no

    Se me ocurre que bypaseando la IP destino (en el caso de tus imagenes 94.211.174.135) …

    Y sino, agregando en Custom options la línea ignore_expect_100 on

    Contanos cómo te fue



  • buenas tardes, hice como me indicaron, habilite esa ip de destino para que no pase por el proxy y añadí la línea ignore_expect_100 on, el tema es que la versión de squid que uso no tiene la casilla de custom options, asi que añadí dicha línea en Custom ACLS (Before_Auth),
    les adjunto las capturas así ven como lo hice, pero sigo teniendo el mismo error. :'(

    ![con ip destino habilitado.jpg](/public/imported_attachments/1/con ip destino habilitado.jpg)
    ![con ip destino habilitado.jpg_thumb](/public/imported_attachments/1/con ip destino habilitado.jpg_thumb)
    ![ognore expect en on.jpg](/public/imported_attachments/1/ognore expect en on.jpg)
    ![ognore expect en on.jpg_thumb](/public/imported_attachments/1/ognore expect en on.jpg_thumb)
    ![mismo error.jpg](/public/imported_attachments/1/mismo error.jpg)
    ![mismo error.jpg_thumb](/public/imported_attachments/1/mismo error.jpg_thumb)





  • ok, podés compartir el squid.conf con esa línea incluida y después eliminar el ignore_expect_100 on??

    Acá encontré algo, está en portugués pero quizás te sirva. Dicen que tenés que permitir las extenciones del tipo application/octet-stream

    en un squid.conf configurado a mano sería

    acl rtmtp req_mime_type application/octet-stream

    .
    .
    .
    http_access allow rtmtp all

    Hay que traducirlo para pfsense, pero nos vamos acercando.

    Te dejo el link https://forum.pfsense.org/index.php?topic=61896.15

    Saludos!



  • buenas tardes, les comento hice todos los pasos que me indicaron y el problema no lo pude resolver, así que lo que hice fue instalar de cero el pfsense e instalar los paquetes squid 2.7.9  , el squidguard y el antivirus havp, aprovechando que a la noche no había nadie usando el internet, y para mi sorpresa pude ver perfectamente dicha película y probé otras varias y puedo verlas a todas, así que lo que deduzco es que el paquete squid3 con el antivirus que tiene incorporado no se lleva bien con algunas direcciones rtmtp. La instalación completa con dichos paquetes no me llevo mas de 25 minutos eso es una de las grandes bondades que tiene pfsense.
    Agradezco la ayuda que me brindaron y estoy agradecido por la solidaridad que hay en el foro, un saludo desde Argentina, y les adjunto las capturas con los paquetes instalados y la película viéndola perfectamente



    ![con squid y havp.jpg](/public/imported_attachments/1/con squid y havp.jpg)
    ![con squid y havp.jpg_thumb](/public/imported_attachments/1/con squid y havp.jpg_thumb)



  • Digan lo que digan, squid 2.7 es perfectamente estable. Siempre recomiendan en las listas de correo de squid que mantengamos actualizado el paquete, sin embargo el development acarrea algunos bugs engorrosos para solucionar a mano.

    el 2.7 me funciona perfecto, aunque claro, para tener filtrado https en forma transparente, necesitás al menos la versión 3 de squid.

    Me alegra que hayas podido solucionar tu inconveniente. Lamento que mi ayuda no haya sido suficiente y haya sido necesaria una reinstalación pero bueno, fue lo más eficaz que pudiste haber hecho

    Saludos, también, desde Argentina



  • No sabia que tenias habilitado el servicio del clamav, aunque… creo que debí prestar mas atención a las capturas, jeje. El clamav es sabido que dá uno que otro problemilla, al parecer hay que hacerle uno que otro ajuste especial antes de "soltarlo al campo". En mi caso, como me bloqueaba varias cosas, entonces decidí dejarlo deshabilitado. Si te vuelves a animar con squid3, deja deshabilitado el antivirus o, si quieres usarlo, verifica como configurarlo (y de paso compartes que también me interesa  ;D )
    Saludos!