VPN through squid proxy not connecting (split tunneling through squid proxy)



  • Hi all, hope this is the correct section for this, been having a very hard time at this.

    I have a non transparent proxy (wpad using squid3 0.2.8) setup and I am using at&t network client to connect to a private network.
    When I connect directly (not going through the proxy) everything works as it should (Note: doing this is not a long term solution and a bit of a pain to do every time someone wants to use the vpn).

    When I try to go through the proxy and block ports 80 and 443 (NOTE here I setup at&t network client to use the proxy) first it cannot connect, checking the logs I see that it cannot connect to the server, I have tired to just pass the blocked server ips but to test it I unblocked port 80 and 443 and it is then able to connect HOWEVER webpages from the private network do not load or only half load.

    I then tried to make pass rules in the wpad to bypass the proxy (had a little success) however the rabbit hole of server ips or domains I need to find seems endless and does not always fix the issue.

    Has anyone got any advice for me?
    Thanks



  • ~~ok found a fix

    changed
    Firewall: Rules LAN FROM~~

    IPv4 *	LAN NET	*	*	*	*	none	 	Default allow LAN to any rule 	
    IPv6 *	LAN NET	*	*	*	*	none	 	Default allow LAN IPv6 to any rule 
    

    TO

    IPv4 *	*	*	*	*	*	none	 	Default allow LAN to any rule 	
    IPv6 *	*	*	*	*	*	none	 	Default allow LAN IPv6 to any rule 
    

    arr, made an update in my wpad which took out the proxy, that's why it worked :(



  • Ok think i found the issue, it is a split tunnel through squid issue.



  • Still have not fixed this issue.

    Has anyone been able to get split tunnel working through squid?



  • Could this be an issue with pfsense passing the wpad to the local connection and the vpn connecting?

    Because when I do not use a wpad and go direct there is no connection issue.



  • No idea.  I've never done what you're doing there.