Captive portal em 2ª placa de rede



  • Olá, tenho o seguinte cenário, 1 placa de rede LAN (192.168.3.0/16) que são usuários da rede cabeada e estão sendo filtrados pelo squidguard, e tenho 2ª placa de rede (10.0.0.0/24) que estão ligados os roteadores e ativado o Captive Portal, porém todo conteúdo desta segunda placa não está sendo filtrado pelas regras do blacklist, não estou conseguindo fazer isso funcionar, alguém poderia dar ajuda?



  • Seu captive portal esta funcionando (aparece a tela de Login)?

    No proxy server marcou para usar proxy transparente para a segunda interface?

    Fechou as portas 80 e 443 no Firewall?



  • A tela do login está aparecendo, e marquei uso proxy transparente para segunda interface, agoras as portas estão abertas no firewall, mais se fechar o pfsense vai redirecionar para 3128 do meu proxy ??



  • Tentei de todas as formas e não consegui realmente pesquisei aqui no forum e youtube e nada, meu cenário é seguinte :

    LAN1 - 192.168.3.0/16
    LAN2 - 10.0.0.0/24

    e ainda tenho 2 WAN:

    WAN1 - link dedicado
    WAN2 - link publico

    já criei failover dos links WAN e LAN1 está para todos os equipamentos cabeados passando pelo proxy td beleza, squidguard efetuando todas as regras e passa pelo squid3 tudo ok.

    LAN2 - é a porta que estão ligados os AP´s e é a porta ativa para captive portal, que está tudo ok, exibindo a página de autenticação e autenticando normal, porém não está passando pelas regras do proxy.

    Gostaria de saber como conseguir dar continuidade nisso, agradeço desde já alguem que tenha uma luz para me auxiliar



  • Para facilitar, qual versao do pfsense, squid e squidguard que estas usando?



  • pfsense versão : 2.2.4
    squid3 0.2.8
    squidguard 1.9.14



  • @Fernando:

    A tela do login está aparecendo, e marquei uso proxy transparente para segunda interface, agoras as portas estão abertas no firewall, mais se fechar o pfsense vai redirecionar para 3128 do meu proxy ??

    Se marcar o proxy transparente para a segunda interface todo o trafego da porta 80 será redirecionando para a porta 3128, o problema é a porta 443 que para usar o proxy transparente tem que instalar um certificado em todas as estações, inviável para visitantes. O que poderia resolver isso seria passar a configuração do proxy por WPAD, mas os dispositivos móveis não conseguem receber esta configuração automaticamente.



  • Segue abaixo as telas do proxy, ainda não consegui solução"








  • Percebi que o Range 10.0.0.0/24 não está passando pelo PROXY



  • Não está passando, mais não estou conseguindo fazer isso, já coloquei Proxy server, para efetuar na lan2 que no momento está sem proxy e nada !



  • @Fernando:

    Não está passando, mais não estou conseguindo fazer isso, já coloquei Proxy server, para efetuar na lan2 que no momento está sem proxy e nada !

    Por acaso, não tem outro roteador na rede para esta rede 10.0.0.0/24?



  • O único DHCP operando é os gerados pelo pfsense, sendo que na lan1 DHCP gerando para 192.168.3.0/16 e na LAN2 gerando IP 10.0.0.0/24 apenas ativa no captive portal.



  • ola pessoal, estou com o mesmo problema, eu estava procurando documentação para multi-lan mas parece o site do mesmo foi removido.
    meu cenário é, tenho pfsense 2.2.3 em uma rede 192.168.1.0 com squidguard 1.9.14 e squid 3 0.2.8 com duas WAN'S,  tudo com placa de rede física, atualmente rodo o captive portal na interface lan, e aqueles clientes que não são da loja não tem MaC das placas cadastrado, consequentemente necessário voucher para navegar, blz esta ok, mas este clientes externos acessam meus compartilhamentos se quiserem quando conectados pelo wi-fi.
    Aí surgiu a necessidade de separar as redes, coloquei mais uma placa de rede para 192.168.2.0  somente para o router wi-fi, habilitei a mesma no squid e no captive, criei o dhcp e a regra no firewall, porem nao acesso nem se quer a pagina do captive quanto mais a internet, preciso de detalhes de multi-lan de como fazer ?  vi alguns vídeos mas parece não ser exatamente o que preciso saber.
    obrigado.  :-\










  • até o momento sem novidades ou o proxy reconhece LAN1 ou LAN2, não consigo fazer ele reconhecer as 2 LAN no proxy :(



  • Caro Fernando, parece que estamos com mesmo problema em passar a lan2 pelo proxy, e caso eu não queira passar minha lan2 pelo proxy, usando apenas regras de firewall posso? como você fez para rotear para lan2 ? pois na minha Lan2 não consigo se quer acessar internet. (lembrando que ativei a lan2 no captive portal) como mostra imagens anexo no meu post anterior. alguém tem documentação referente a multi lan?, pois no docs não está mais.
    obrigado.



  • Olá venho dizer que após várias pesquisas e uma grande dica do Marcello em um outro post, cheguei em uma solução e consegui que o proxy (Squid3) e filtro (Squidguard) passe todas suas conexões porta 80 passe pela porta 3128, nas configurações da LAN 1 inseri meu range de ip 192.168.3.0/16 , e na LAN2 inseri o meu range para os meus wifi que passarão pelo Captive portal no range 10.0.0.0/24, apenas tirei loopback das configurações do proxy e reinstalei todos os pacotes novamento (squid,squidguard,lightsquid), a única coisa que ainda não acertei foi o lightsquid que não está exibindo, os acessos, mais um muito obrigado a todos que auxiliaram de alguma forma.



  • Ola Fernando, pode me informar qual foi o outro post do Marcelo ?, ainda não consegui rotear para Lan2, poderia me ajudar ?
    obrigado.



  • Fernando, qual o problema do LightSquid?



  • Consegui acertar o Lightsquid, ele não estava efetuando a captação dos conteúdos dos usuários, eu desinstalei o pacote totalmente, reiniciei o pfsense e reinstalei novamente e voltou a funcionar novamente.



  • Tiago, veja todo conteúdo desse post sobre a configuração e o que o Marcelo me passou era para não deixar o loopback ativo no PROXY SERVER , reiniciei o pfsense e começou a passar as conexões da LAN2 no proxy, agora como configurei tudo para funcionar com 2 interfaces LAN no pfsense está tudo neste post mesmo.



  • Fernando, consegui rotear, fiz os passos que você disse e agora ambas redes passam pelo proxy,  acontece que o serviço do squid fica caindo muito, qual é o post que você citou sobre o loop back ??, obrigado