Generating non working certificates



  • Hi there,

    I have setup OpenVPN on PFsense using the webgui and a tutorial. I made a CA and with that CA I made a user cert and a server cert.

    When I connect with Windows 7 to pfsense the log stated that there was an error with the certificate.

    After googling I learned that the certificates for the user and the server both have a setting: CA: No.

    After viewing the certificates that is also the problem with my certificates.

    I have wiped pfsense and reinstalled pfsense and openvpn.

    The problem persisted.

    How can I make a certificate with CA: Yes.

    Thanks,

    Sebastiaan.


  • Rebel Alliance Developer Netgate

    Server and user certificates should NOT be a CA. That is not the problem. Only the actual CA should be a CA.



  • Hi jimp,

    When following the tutorial here https://www.youtube.com/watch?v=VdAHVSTl1ys I was not able to connect. The log is displayed below.

    After googling unsupported certificate purpose I saw some people telling about pfsense generating certificates that do not work.

    They find the solution in regenerating the certificates.

    I tried this but I failed. I could only remove the user cert. Not the server cert.

    Then I restored pfsense from backup. Did the same tutorial again. I hoped this time the certificates would work.

    They did not.

    Can somebody tell me what to do to make openvpn work?

    Thanks very much.

    Sebastiaan.

    This is the log from the Win 64b OpenVPN client:

    Fri Aug 21 08:37:23 2015 VERIFY ERROR: depth=0, error=unsupported certificate purpose: C=NL, ST=Noord Brabant, L=Grave, O=Familie Kop, emailAddress=sebastiaan@famkop.nl, CN=sebastiaankop

    Fri Aug 21 08:37:23 2015 TLS_ERROR: BIO read tls_read_plaintext error: error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed

    Fri Aug 21 08:37:23 2015 TLS Error: TLS object -> incoming plaintext read error
    Fri Aug 21 08:37:23 2015 TLS Error: TLS handshake failed
    Fri Aug 21 08:37:23 2015 SIGUSR1[soft,tls-error] received, process restarting
    Fri Aug 21 08:37:25 2015 UDPv4 link local (bound): [undef]
    Fri Aug 21 08:37:25 2015 UDPv4 link remote: [AF_INET]84.29.137.252:1194


  • Rebel Alliance Developer Netgate

    Most likely you did not select "Server Certificate" when generating the OpenVPN server certificate but accidentally left it on "User Certificate". Make a new server certificate and be sure to set it to be a Server.


  • LAYER 8 Global Moderator

    Why are you trying to follow a video anything from 2012? When clickity clickity through the wizard and it will setup both new CA and server cert for you..

    To get openvpn to work - run through the wizard and answer the questions its really that simple!!




  • Hi jimp,

    You where right.

    I issued the client certificate while it had to be the server certificate.

    It is working now.

    Many thanks,

    Sebastiaan.


Log in to reply