• Bonjour à tous,

    Voici mon problème, je désire avoir sur un même port ethernet une interface "normal" en DHCP et un vlan lui aussi en DHCP, pour gérer un reseau de point d'accès
    J'ai donc créé mes 2 interfaces, LAN2 pour la classic et VLAN_2_10 pour le vlan sur le meme port ethernet (bce3)

    J'ai donné une adresse fixe aux deux, 192.168.20.1 et 192.168.220 (vlan)
    J'ai ouvert le firewall pour tout authorisé et activé le DHCP server sur les 2.

    J'ai branché un point d'accès en direct sur pfsense, pas de switch intermédiaire pour être sur que rien ne soit touché au niveau du vlan.
    Le point d'accès est sous openwrt pour information.

    L'interface principale du point d'accès prend bien son IP en 192.168.20.x, par contre rien sur l'interface sur le vlan 10.
    J'ai effectué une capture de paquets coté pfsense sur l'interface vlan_2_10 et je vois arriver des paquets de demande DHCP toute les 3 secondes, mais jamais le moindre retour.
    Au passage je vois aussi ces paquet sur l'interface LAN2, tagué sur le vlan 10.

    Au niveau des logs du DHCP j'ai juste comme quoi le serveur écoute bien sur l'interface vlan.

    J'espère avoir été clair et que quelqu'un à une idée, je bloc depuis 1semaine sur ça, c'est la première fois que j'utilise les vlans sur pfsense.

    Merci.


  • J'ai donné une adresse fixe aux deux, 192.168.20.1 et 192.168.220 (vlan)

    Il y a une coquille bien sûr, mais pouvez vous donner le numéro de réseau de chaque vlan ?
    Une copie d'écran de votre configuration de vlan sur l'interface physique serait bienvenue.

    L'interface principale du point d'accès prend bien son IP en 192.168.20.x, par contre rien sur l'interface sur le vlan 10.

    Je ne comprend pas ce que veut dire "interface principale".
    Pour info, lors de la création de Vlan sur Pfsense j'ai toujours redémarré Pfsense pour avoir une configuration fonctionnelle. Cela dépend aussi de la façon dont vous avez monté vos Vlan sur l'interface.


  • Au lieu de perdre bêtement une semaine, il eut été plus judicieux de parcourir ce forum et la doc de Pf.

    Vous auriez appris qu'il ne faut pas (pour diverses raisons)  essayer de faire cohabiter sur une même interface, un réseau physique et des réseaux virtuels !

    Donc, une interface physique sur pf est soit un réseau physique soit des Vlan.


  • C'est bien ce que je soupçonne mais je veux le vérifier. Car en effet cela ne fonctionne pas !


  • Merci pour votre retour rapide.

    Vous pensez bien que j'ai cherché avant de poster ici, je n'ai pas passé ce temps sans chercher.

    En effet j'ai mis un réseau physique et un vlan sur la même interface.
    Je vais modifier tout ça pour voir ce que cela donne.


  • Nécessaire mais pas forcément suffisant pour ce que vous souhaitez faire.


  • Donc après n'avoir mis que des Vlan sur l'interface et redémarré PFsense, tout fonctionne comme je le désir :)
    Dommage que l'on ne puisse avoir un réseau physique et virtuel en même temps, mais ça ira comme ça.

    Merci.


  • Merci de modifier le titre de votre post avec [Résolu] ;) cela pourrai servir à d'autres :)