Captive portal - Authenticated users displayed as unauthenticated



  • Hello,

    I've update pfSense from 2.2.2 to 2.2.4 and since that when users authenticate through CP they are shown as unauthenticated in Status > CP > Active users and in the CP status widget in the home page.
    Is this an identified bug?

    Regards
    Romain



  • @rct:

    I've update pfSense from 2.2 to 2.4 ….

    I advise you to abandon future development versions.

    @rct:

    Is this an identified bug?

    Better yet : this bug hans't been born yet ;)

    If not, 2.2.4 (Captive Portal using Local Login Manager) works great:




  • 2.2.4 is the latest stable community version not a development version !?!

    This bug is just a little annoying but it's not enough to give up our CP/radius/LDAP integration ;)



  • Hmm I just realized I wrote 2.4… Oups... And I understand now why you wrote that :D

    I'll modify the initial message



  • @rct:

    This bug is just a little annoying but it's not enough to give up our CP/radius/LDAP integration ;)

    Ah …
    Didn't know that you were using something like "CP/radius/LDAP integration".
    I'm using the more simple PfSense local manager. Works.

    If you want a detailed answer, start putting yours first.


  • LAYER 8 Netgate

    What are the authentication settings on your CP?  none and vouchers will always show as unauthenticated.



  • @Derelict:

    What are the authentication settings on your CP?  none and vouchers will always show as unauthenticated.

    Bulls eye  :)

    "unauthenticated" doesn't mean that "CP/radius/LDAP integration" isn't doing its job.
    IMHO : from what I make of it.



  • Sorry not to have best described my initial configuration and thank you Derelict it was the problem : for an unknown reason the auth mode was set to none and we also use vouchers (and I'm pretty sure auth portal appeared and was authenticating to ldap).

    I've just set auth mode to radius and now authenticated users appears correctly.

    Thanks for your help


Log in to reply