Squid3 automatically stop at 00:00 (50/50 solved)



  • hi, all

    I had setup squid3 on my 2.2.4 build 2 days ago. (Transparent Proxy + local cache)

    I found that the services squid stop at 00:00 in these 2 day.

    Appreciate for the advices.

    Aug 29 21:17:17 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Aug 29 21:18:13 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 29 21:18:14 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 29 21:18:14 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 29 21:34:32 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Aug 29 21:36:58 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Aug 29 22:05:59 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 29 22:10:29 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Aug 29 22:11:48 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Aug 29 22:23:47 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 29 22:23:47 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 29 22:23:48 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 29 22:49:36 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Aug 29 23:06:04 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 29 23:06:05 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 29 23:06:05 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 29 23:28:28 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Aug 29 23:42:48 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    Aug 29 23:57:28 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 29 23:57:28 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 29 23:57:29 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609B:SSL routines:SSL23_GET_CLIENT_HELLO:https proxy request
    Aug 30 00:00:00 	php: swapstate_check.php: Creating Squid cache dir /var/squid/cache
    Aug 30 00:00:00 	php: swapstate_check.php: Creating squid cache subdirs in /var/squid/cache
    Aug 30 00:00:05 	squid[41159]: Squid Parent: (squid-1) process 41469 exited with status 0
    Aug 30 00:00:05 	php: swapstate_check.php: The command '/usr/pbi/squid-amd64/sbin/squid -k kill -f /usr/pbi/squid-amd64/local/etc/squid/squid.conf' returned 
    
    exit code '1', the output was 'squid: ERROR: No running copy'
    Aug 30 00:00:05 	squid[17960]: Squid Parent: will start 1 kids
    Aug 30 00:00:05 	squid[17960]: Squid Parent: (squid-1) process 18355 started
    Aug 30 00:01:13 	kernel: igb1: link state changed to DOWN
    Aug 30 00:01:15 	kernel: igb1: link state changed to UP
    Aug 30 00:01:05 	check_reload_status: Linkup starting igb1
    Aug 30 00:01:06 	check_reload_status: Linkup starting igb1
    Aug 30 00:01:06 	php-fpm[36533]: /rc.linkup: Hotplug event detected for LAN(lan) but ignoring since interface is configured with static IP (192.168.x.xxx )
    Aug 30 00:01:07 	php-fpm[36533]: /rc.linkup: Hotplug event detected for LAN(lan) but ignoring since interface is configured with static IP (192.168.x.xxx )
    Aug 30 00:01:07 	check_reload_status: rc.newwanip starting igb1
    Aug 30 00:01:08 	php-fpm[36533]: /rc.newwanip: rc.newwanip: Info: starting on igb1.
    Aug 30 00:01:08 	php-fpm[36533]: /rc.newwanip: rc.newwanip: on (IP address: 192.168.x.xxx) (interface: LAN[lan]) (real interface: igb1).
    Aug 30 00:01:10 	Squid_Alarm[38553]: Squid has exited. Reconfiguring filter.
    Aug 30 00:01:10 	Squid_Alarm[39010]: Attempting restart...
    Aug 30 00:01:11 	check_reload_status: Reloading filter
    Aug 30 00:01:13 	Squid_Alarm[41796]: Reconfiguring filter...
    Aug 30 00:01:13 	check_reload_status: Reloading filter
    Aug 30 00:01:22 	squid[17960]: Squid Parent: (squid-1) process 18355 exited with status 0
    Aug 30 00:01:22 	php: swapstate_check.php: Squid cache and/or swap.state exceeded size limits. Removing and rotating. File was 419832 bytes, 0% of total disk 
    
    space.
    Aug 30 00:01:30 	php-fpm[44782]: /index.php: Successful login for user 'admin' from: 192.168.x.xx
    Aug 30 00:01:30 	php-fpm[44782]: /index.php: Successful login for user 'admin' from: 192.168.x.xx
    Aug 30 00:03:43 	squid[99021]: Squid Parent: will start 1 kids
    Aug 30 00:03:43 	squid[99021]: Squid Parent: (squid-1) process 99723 started
    Aug 30 00:04:50 	Squid_Alarm[29184]: Squid has resumed. Reconfiguring filter.
    Aug 30 00:04:50 	check_reload_status: Reloading filter
    Aug 30 00:05:15 	lighttpd[28611]: (connections.c.305) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request
    ```![Capture.JPG](/public/_imported_attachments_/1/Capture.JPG)
    ![Capture.JPG_thumb](/public/_imported_attachments_/1/Capture.JPG_thumb)

  • Banned

    Perhaps install cron package and see what's scheduled for midnight?



  • Thanks for the help :D

    I found that swapstate_check.php clean is scheduled on 00:00.

    I also found this thread
    https://forum.pfsense.org/index.php?topic=91796.0

    lets try to disable "clear cache on log rotate" :P