GW Monitoring (APinger)



  • Hallo zusammen,

    ich stelle hier bei mir ein sehr merkwürdiges Problem fest….

    meine config:

    pfsense 2.2.4
    1x WAN DHCP
    1x OpenVPN Client

    2x Lan

    Vorhaben:
    Router holt sich Internet via WAN                          Ok
    Router baut direkt VPN auf                                    Ok
    Router soll gesamten Traffic durch Tunnel leiten    Fail

    Das Problem liegt jedoch nicht an der VPN Config, sondern am APinger, denn wenn ich diesen neu starte funktioniert alles einwandfrei.
    Starte ich den Router neu so beginnt es wieder von vorne. Laut APinger Log sieht es aber so aus als würde er das GW richtig monitoren... markiert es jedoch nicht wieder als UP.

    Hatte schonmal jemand das Problem?



  • Ja der APinger ist das Letzte !
    Hier hoffe ich, dass seitens Pfsense mal nachgebessert oder das Ding komplett ersetzt wird.
    Das Tool hat mir schon einige schlaflose Nächte und volle Emailpostfächer bereitet :/

    Ich würde dir enpfehlen, statt das Default-Gateway auf die VPN Strecke umzubiegen, einfach nur den LAN-Interfaces ein neues Gateway mittels FW-Rule zu verpassen.

    Gruß
    Rubinho



  • Moin,

    schau dir mal die Einstellungen unter:

    System > Advanced > Miscellaneous > Gateway Monitoring > State Killing on Gateway Failure

    an.

    Hornetx11



  • Na ja … umgebogen via Rule habe ich es ... jedoch wenn man eine Failover Config erstellen möchte dann ist man auf den APinger angwiesen.

    Was das State Killing angeht, so kenne ich diese Option... hilft jedoch nicht.

    Ich habe inzwischen herausgefunden das nach einem Neustart in der apinger.conf nur das WAN IF aufgeführt ist, das VPN IF taucht nicht auf.
    Nach einem Neustart von APinger taucht dieses jedoch dort auf.

    Scheinbar wird der APinger vor dem GW gestartet, und das GW fehlt deswegen in der Config. Hier fehlt irgentwo scheinbar ein trigger...