PfSense 2.2.4 mit squid und squidguard



  • Hallo zusammen,

    bin Neuling im Bereich der PFSense.
    Ich habe versucht die aktuelle squid und squidGuard zum Laufen zu bringen. Bis jetzt leider ohne Erfolg.
    Gibt es eine bestimmte Reihenfolge wie ich diese installieren soll?
    Habe mir paar Videos bei YouTube angeschaut und mich daran entlang gehangelt nur leider ohne Erfolg.
    Unter Service ist der squid im Status Running und squidGuard Stopped. Leider bekomme ich diese nur kurz zum Laufen und dann sind beide wieder gestopped.

    Beim Proxy Server unter  Auth Settings habe ich folgenden Fehler:

    Proxy server: Authentication help

    errors

    The following input errors were detected:

    Authentication cannot be enabled while transparent proxy mode is enabled

    Im Proxy Filter „General settings“ spring der Status immer wieder auf Started und Stopped. Im Service sind beide Dienste im Wechsel Running und Stopped. Wenn beide Dienste in der PFSense an sind ist das Internet Langsam und Träge oder geht garnicht. Beide ausgestellt und wieder alles normal und schnell.

    Jemand von euch eine Idee?

    Gruss



  • Moin,

    The following input errors were detected:

    Authentication cannot be enabled while transparent proxy mode is enabled

    Transparent Proxy schon mal deaktiviert?

    -teddy



  • Hallo Teddy,

    ja danke jetzt läuft es mal. Habe das auch schon Probiert aber da wollte die Kiste nicht.
    Jetzt muss nur noch der Filter greifen. Da lässt er gerade alles zu was er blocken sollte.

    Mal ist der Proxy Filter Started dann wieder Stopped. Dann zeigt er mir im Proxy Started und im Service Stopped an.

    squid läuft nicht durch mal startet mal stopped er. Keine Ahnung was das soll. Kennt noch jemand das Problem?

    Hier ein Auszug vom System Log

    Sep 2 14:11:15 squid[69029]: Squid Parent: child process 69602 exited due to signal 6
    Sep 2 14:11:15 kernel: pid 69602 (squid), uid 62: exited on signal 6
    Sep 2 14:11:17 Squid_Alarm[7904]: Reconfiguring filter…
    Sep 2 14:11:18 check_reload_status: Reloading filter
    Sep 2 14:11:18 Squid_Alarm[9778]: Squid has resumed. Reconfiguring filter.
    Sep 2 14:11:18 squid[69029]: Squid Parent: child process 10341 started
    Sep 2 14:11:20 squid[10341]: The url_rewriter helpers are crashing too rapidly, need help!
    Sep 2 14:11:20 squid[69029]: Squid Parent: child process 10341 exited due to signal 6
    Sep 2 14:11:20 kernel: pid 10341 (squid), uid 62: exited on signal 6
    Sep 2 14:11:20 check_reload_status: Reloading filter
    Sep 2 14:11:23 squid[69029]: Squid Parent: child process 51115 started
    Sep 2 14:11:25 squid[51115]: The url_rewriter helpers are crashing too rapidly, need help!
    Sep 2 14:11:25 kernel: pid 51115 (squid), uid 62: exited on signal 6
    Sep 2 14:11:25 squid[69029]: Squid Parent: child process 51115 exited due to signal 6
    Sep 2 14:11:28 squid[69029]: Squid Parent: child process 87898 started
    Sep 2 14:11:29 squid[87898]: The url_rewriter helpers are crashing too rapidly, need help!
    Sep 2 14:11:29 kernel: pid 87898 (squid), uid 62: exited on signal 6
    Sep 2 14:11:29 squid[69029]: Squid Parent: child process 87898 exited due to signal 6
    Sep 2 14:11:33 squid[69029]: Squid Parent: child process 38408 started
    Sep 2 14:11:34 squid[38408]: The url_rewriter helpers are crashing too rapidly, need help!
    Sep 2 14:11:34 kernel: pid 38408 (squid), uid 62: exited on signal 6
    Sep 2 14:11:34 squid[69029]: Squid Parent: child process 38408 exited due to signal 6
    Sep 2 14:11:34 squid[69029]: Exiting due to repeated, frequent failures
    Sep 2 14:12:16 Squid_Alarm[77419]: Squid has exited. Reconfiguring filter.
    Sep 2 14:12:16 Squid_Alarm[77951]: Attempting restart…
    Sep 2 14:12:16 squid[82224]: Squid Parent: child process 82681 started
    Sep 2 14:12:18 squid[82681]: The url_rewriter helpers are crashing too rapidly, need help!

    Danke schonmal für die Hilfe

    SaKe



  • Hey,

    ich habe Squid samt Suidguard im Einsatz, auch mehrmals schon neu einrichten können.

    Laut einem alten Beitrag in irgendeinem Forum muss man SquidGuard immer vor(!) Squid als Package installieren. Im Anschluss erst Squid (in meinem Fall immer Version 3, die 2 sei unkomplizierter) installieren. Funktionierte immer!

    Um dann den Filter greifen zu lassen sind auch immer die selben Klicks notwendig, da sonst nach einem Distributionsupdate oder größeren Änderungen der Filter wieder alles durchlässt. Das sind ein Klick auf "Save" in den betreffenden ACL's, dann ein Klick auf "Save" im "general settings" gefolgt von einem "Apply" auf der selben Seite.

    Habe viel probiert, es klappte aber immer nur genau so, auch nur in den genannten Reihenfolgen.

    Mein Squid läuft übrigens nicht-transparent.