• I just upgraded from v. 0.88 to Beta2 (should have longtime ago) and on the 0.88 the DHCP didn't really work well on the wireless so I used a static IP, and that worked great.

    Now when installed Beta2 I started out with static IP configuration because I knew that worked, and the client could see the network and said it connected as it should and on the pfSense box I could see the client too but nothing worked except that ? (no I did add a firewall rule).

    I then (after a few hours) decided to try DHCP and that worked! just like that? no problems at all :) that is great but why can't I configure a client to use static IP anymore ??


  • Do you have enabled the static ARP option for your DHCP server?


  • no I didn't touch the DHCP setup at all, I just setup the opt2 (wireless) to static IP 192.168.2.1 /24 and expected that my client would be able to connect with a static IP 192.168.2.5 (unchanged from when it worked with v. 0.88).

    the client said it connected and the siglan is 100%, and in the pfsense system log I could see  " <mac address="">associated" and " <mac address="">authenticated", but now when I look again it also says " <mac address="">WPA: group key handshake completed (WPA)".  I don't recall seeing that in the log when I used the static IP?</mac></mac></mac>