Balanceo MultiWAN solo funciona con un ISP



  • Buen día.

    Tengo Pfsense configurado, con 2 WAN y una LAN, la primera wan1 es mi proveedor de servicios llamado level3 y el segundo proveedor es cantv como wan2

    Cree 2 grupos de gateways:
    BalanceoA donde  wan1 tiene tier 1  y wan2 tiene tier2.  y
    BalanceoB donde  wan2 tiene tier 1 y  wan1 tiene tier2.

    Por BalanceoA sale solamente conexión segura (HTTPS) (443)
    Por BalanceoB sale el resto (puerto 80, 53,123)

    al Desconectar BalanceoA, la conexión segura se empieza a ir por el gateway wan2, es decir cantv,  los usuarios siguen navegando por el gateway BalanceoB junto con la conexión segura (443).

    Pero no funciona a lo contrario. Cuando quito BalanceoB, solo queda funcionando la conexión segura (https) que es la que va por BalanceoA,  es decir no me funciona la navegación que va por BalanceoB.

    Creo que esto tiene que ver que el gateway de cantv (wan2) es el Default Gateway General para el pfsense. Por tal motivo la primera prueba supongo que me funciono, ya que el gateway down no es el defaul gateway del pfsense.

    Que puedo hacer en este caso? dependo del  procedimiento manual si se cae el wan2?

    Gracias.


  • Rebel Alliance

    Para "Balancear" las "WAN" del grupo deben estar en el mismo "Tier" lo que tienes armado el un "Fail Over" ;)

    https://doc.pfsense.org/index.php/Multi-WAN

    https://doc.pfsense.org/index.php/Gateway_Settings

    https://doc.pfsense.org/index.php/Troubleshoot_Outbound_Load_Balancing_Issues

    Si quieres mas ayuda, por favor, adjunta capturas de pantalla donde podamos "ver" "todo" lo que hiciste….



  • Gracias por responder ptt

    En realidad lo que quiero hacer es el failover

    Adjunto la conf de los grupos de gateway.

    Si verificas la imagen, Wan2antv  es el default gateway del pfsense

    Mi regla es basica, conexion https por level3, resto de las conexiones por cantv.

    Si desconecto level3, todo sigue normal, se empieza a navegar conexion segura por cantv.

    Pero si ocurre lo contrario, es decir desconecto cantv (que es el default gateway de pfsense) solo me queda funcionando la conexion segura (https) que es la que va por level3.

    Es decir muere las conexiones que van por cantv.

    Saludos.




  • Tienes DNS dados de alta en las dos interfaces ?

    Eso lo puedes verificar en la configuracion general. No tienes , agrega los necesarios


  • Rebel Alliance

    Con la "info" que nos das… imposible ayudarte  ???

    Necesitamos "ver" el resto de la configuración...  además de lo que preguntó el compañero,  adjunta captura de pantalla de las Reglas de FW de la LAN, y de cualquier otra "cosa" que hayas "tocado" (modificado)



  • Saludos, Adjunto las imágenes solicitadas.

    Recapitulando, tengo 2 reglas LAN, una para que todo lo que va a 443 salga por level3, el resto por el otro enlace llamado GwCantv.

    Cuando desconecto Level3, las conexiones 443 pasan por Cantv, es decir sigo teniendo servicio al 100%.

    Cuando desconecto Cantv, solo me queda trabajando 443, lo demas queda sin servicio.

    El default gateway de pfsense es Cantv. Sera por eso?

    Adjunto todo.

    Saludos.