[RESUELTO] OpenVPN falla



  • Buenas tardes estimados,

    Les escribo en esta oportunidad porque no logro hacer funcionar un servidor OpenVPN, en dias anteriores logré hacerlo siguiendo el tutorial para clientes Road Warrior, logré ver los recursos de la red local con un cliente remoto y todo perfecto.

    Actualmente intento acceder y no funciona el acceso, logro conexión a la red local pero no logro ver los recursos compartidos.

    Pensé que fue fallo de algun paquete q instale o que estuve curioseando, y decidí hacer la instalación limpia de nuevo para hacerlo funcionar de nuevo y entregar el equipo.

    Lo hice y no funcionó, ahora bien, veo que el "device mode" esta por defecto en "tun" he leído que en la maq de windows se monta un adaptador "tap" hago el cambio a "tap" en el servidor OpenVPN y no arranca (en "status > services" está detenido y no arranca), consulto el log y esto es lo que me arroja

    Sep 10 08:29:45	openvpn[1584]: event_wait : Interrupted system call (code=4)
    Sep 10 08:29:45	openvpn[1584]: /usr/local/sbin/ovpn-linkdown ovpns1 1500 1558 192.168.6.1 192.168.6.2 init
    Sep 10 08:29:45	openvpn[1584]: SIGTERM[hard,] received, process exiting
    Sep 10 08:29:45	openvpn[37534]: OpenVPN 2.3.7 i386-portbld-freebsd10.1 [SSL (OpenSSL)] [LZO] [MH] [IPv6] built on Jun 19 2015
    Sep 10 08:29:45	openvpn[37534]: library versions: OpenSSL 1.0.1l-freebsd 15 Jan 2015, LZO 2.09
    Sep 10 08:29:45	openvpn[37644]: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
    Sep 10 08:29:45	openvpn[37644]: Control Channel Authentication: using '/var/etc/openvpn/server1.tls-auth' as a OpenVPN static key file
    Sep 10 08:29:45	openvpn[37644]: TUN/TAP device ovpns1 exists previously, keep at program end
    Sep 10 08:29:45	openvpn[37644]: TUN/TAP device /dev/tap1 opened
    Sep 10 08:29:45	openvpn[37644]: do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
    Sep 10 08:29:45	openvpn[37644]: /sbin/ifconfig ovpns1 192.168.6.1 netmask 255.255.255.0 mtu 1500 up
    Sep 10 08:29:45	openvpn[37644]: FreeBSD ifconfig failed: external program exited with error status: 1
    Sep 10 08:29:45	openvpn[37644]: Exiting due to fatal error
    

    No sé si tendrá q ver con la configuración esta o con que sera

    Adicionalmente, qué diferencia hay entre "tun" y "tap"?

    Muchísimas gracias de antemano, estoy atento por si es necesaria otra información

    saludos  :)



  • TUN trabaja con tramas IP y TAP trabaja con tramas Ethernet

    Usa TUN para VPN



  • Muchas gracias por tu respuesta!

    Con TUN se logra conectar, pero no logro ver los recursos de la LAN del pfSense

    Por donde puedo empezar a revisar?



  • Les dejo el estatus que genera el cliente por si es necesario para la consulta

    Thu Sep 10 14:13:49 2015 Warning: cannot open --log file: C:\Program Files\OpenVPN\log\pfSense-udp-1194-prueba2-config.log: Acceso denegado.   (errno=5)
    Thu Sep 10 14:13:49 2015 OpenVPN 2.3.8 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Aug  4 2015
    Thu Sep 10 14:13:49 2015 library versions: OpenSSL 1.0.1p 9 Jul 2015, LZO 2.08
    Thu Sep 10 14:13:57 2015 Control Channel Authentication: using 'pfSense-udp-1194-prueba2-tls.key' as a OpenVPN static key file
    Thu Sep 10 14:13:57 2015 UDPv4 link local (bound): [undef]
    Thu Sep 10 14:13:57 2015 UDPv4 link remote: [AF_INET]201.208.22.236:1194
    Thu Sep 10 14:13:57 2015 WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
    Thu Sep 10 14:14:01 2015 [Server VPN] Peer Connection Initiated with [AF_INET]201.208.22.236:1194
    Thu Sep 10 14:14:03 2015 do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
    Thu Sep 10 14:14:03 2015 open_tun, tt->ipv6=0
    Thu Sep 10 14:14:03 2015 TAP-WIN32 device [TAP] opened: \\.\Global\{C8EA59AC-771C-4D4B-AD94-0461B29D0C76}.tap
    Thu Sep 10 14:14:03 2015 Notified TAP-Windows driver to set a DHCP IP/netmask of 192.168.6.6/255.255.255.252 on interface {C8EA59AC-771C-4D4B-AD94-0461B29D0C76} [DHCP-serv: 192.168.6.5, lease-time: 31536000]
    Thu Sep 10 14:14:08 2015 ROUTE: route addition failed using CreateIpForwardEntry: Acceso denegado.   [status=5 if_index=17]
    Thu Sep 10 14:14:08 2015 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
    Thu Sep 10 14:14:08 2015 ERROR: Windows route add command failed [adaptive]: returned error code 1
    Thu Sep 10 14:14:08 2015 ROUTE: route addition failed using CreateIpForwardEntry: Acceso denegado.   [status=5 if_index=17]
    Thu Sep 10 14:14:08 2015 env_block: add PATH=C:\Windows\System32;C:\WINDOWS;C:\WINDOWS\System32\Wbem
    Thu Sep 10 14:14:08 2015 ERROR: Windows route add command failed [adaptive]: returned error code 1
    Thu Sep 10 14:14:08 2015 Initialization Sequence Completed
    




  • Buen día, eliminé el servidor y la configuración, seguí las instrucciones y la falla persiste :S



  • desinstala el cliente, instalalo en modo administrador si estas con sistemas de win 7+ y ejecuta el cliente en modo administrador, coincido con Pochi con el tema de los manuales  ;D mirate este que esta bien simple y te explica paso a paso http://www.geronet.com.ar/?p=1112 y conta que tal te fue  ;)



  • Buenas tardes estimados!! Resuelta la falla!

    Luego de reinstalar n cantidad de veces el servidor. cliente etc etc etc..

    Ver los logs del cliente y servidor, hubo una línea que me llamo la atencion en el cliente

    "Thu Sep 10 14:14:08 2015 ERROR: Windows route add command failed [adaptive]: returned error code 1"

    La falla es que el gui del open vpn no tiene permiso para ejecutar el comando route, la solucion es ejecutar el OpenVPN Gui con privilegios de administrador.

    Una vez hecho este cambio, funcionó perfecto.

    Esto bajo windows 7.

    Anexo les dejo una imagen para que vean el detalle de la ruta donde por defecto se instala el archivo que se le debe modificar la compatibilidad, boton derecho propiedades, pestaña compatibilidad.

    Saludos :D




  • Funcionando perfecto igualmente con el cliente Tunnelblick para Mac OsX  ;)