Bandwidthd on 2.2.4



  • I upgraded from 2.1.4 (amd64) to 2.2.4, and my bandwidthd no longer works. After playing around for a while, I decided to do a fresh install. Bandwidthd still does not work. I'm surprised not to find anyone else reporting this problem, so I'm hoping it's an easy fix. I ran ldd bandwidthd and got this back:

    libpq.so.5 => not found (0)
            libpcap.so.1 => /usr/local/lib/libpcap.so.1 (0x800852000)
            libgd.so.5 => /usr/local/lib/libgd.so.5 (0x800a9b000)
            libpng15.so.15 => not found (0)
            libm.so.5 => /lib/libm.so.5 (0x800cfd000)
            libc.so.7 => /lib/libc.so.7 (0x800f25000)
            libjpeg.so.8 => /usr/local/lib/libjpeg.so.8 (0x8012b7000)
            libz.so.6 => /lib/libz.so.6 (0x8014f2000)
            libpng16.so.16 => /usr/local/lib/libpng16.so.16 (0x801708000)
            libfreetype.so.6 => /usr/local/lib/libfreetype.so.6 (0x80193d000)
            libfontconfig.so.1 => /usr/local/lib/libfontconfig.so.1 (0x801bd9000)
            libtiff.so.5 => /usr/local/lib/libtiff.so.5 (0x801e19000)
            libbz2.so.4 => /usr/lib/libbz2.so.4 (0x80208b000)
            libexpat.so.1 => /usr/local/lib/libexpat.so.1 (0x80229d000)
            libthr.so.3 => /lib/libthr.so.3 (0x8024c3000)
            liblzma.so.5 => /usr/lib/liblzma.so.5 (0x8026e8000)
            libjbig.so.2 => /usr/local/lib/libjbig.so.2 (0x80290d000)

    What can I do to get the missing packages installed?

    Thanks for any help!

    -TR


  • Banned

    @trcolasanto:

    so I'm hoping it's an easy fix

    LOL. No, it's not. Best bet is doing a clean install, restoring the config and then you can try again.

    
    $ /bin/sh
    # LD_LIBRARY_PATH=/usr/pbi/bandwidthd-amd64/local/lib ldd /usr/pbi/bandwidthd-amd64/local/bandwidthd/bandwidthd
    /usr/pbi/bandwidthd-amd64/local/bandwidthd/bandwidthd:
            libpq.so.5 => /usr/pbi/bandwidthd-amd64/local/lib/libpq.so.5 (0x800852000)
            libpcap.so.1 => /usr/pbi/bandwidthd-amd64/local/lib/libpcap.so.1 (0x800a7e000)
            libgd.so.5 => /usr/pbi/bandwidthd-amd64/local/lib/libgd.so.5 (0x800cc1000)
            libpng15.so.15 => /usr/pbi/bandwidthd-amd64/local/lib/libpng15.so.15 (0x800f23000)
            libm.so.5 => /lib/libm.so.5 (0x801155000)
            libc.so.7 => /lib/libc.so.7 (0x80137d000)
            libintl.so.9 => /usr/pbi/bandwidthd-amd64/local/lib/libintl.so.9 (0x80170f000)
            libssl.so.7 => /usr/lib/libssl.so.7 (0x801919000)
            libcrypto.so.7 => /lib/libcrypto.so.7 (0x801b85000)
            libthr.so.3 => /lib/libthr.so.3 (0x801f7a000)
            libjpeg.so.11 => /usr/pbi/bandwidthd-amd64/local/lib/libjpeg.so.11 (0x80219f000)
            libz.so.6 => /lib/libz.so.6 (0x8023da000)
            libfreetype.so.6 => /usr/pbi/bandwidthd-amd64/local/lib/libfreetype.so.6 (0x8025f0000)
            libfontconfig.so.1 => /usr/pbi/bandwidthd-amd64/local/lib/libfontconfig.so.1 (0x80288a000)
            libtiff.so.4 => /usr/pbi/bandwidthd-amd64/local/lib/libtiff.so.4 (0x802ac8000)
            libbz2.so.4 => /usr/lib/libbz2.so.4 (0x802d39000)
            libexpat.so.6 => /usr/pbi/bandwidthd-amd64/local/lib/libexpat.so.6 (0x802f4b000)
            liblzma.so.5 => /usr/lib/liblzma.so.5 (0x803171000)
            libjbig.so.2 => /usr/pbi/bandwidthd-amd64/local/lib/libjbig.so.2 (0x803396000)
    
    


  • Thanks for the reply. That was actually a clean install. I didn't restore the config. I just did a clean install, ran through the setup wizard, added the Bandwidthd package through the GUI, and did nothing else. I went to Services, tried to start bandwidthd, and it wouldn't start. Not sure how much cleaner it can get. Is there something else I should do first?



  • Another clean install, and now it seems to be working. However this time I went through the bandwidthd configuration page and set everything up. I don't think I did that on the last install. So, I would say this is completely my fault, thanks for entertaining me! pfSense is an awesome product!