Suricata 2.1.6 install completed with failure, and now fails to uninstall



  • The Suricata install completed even though some files failed to download.  pfSense 2.2.4-RELEASE, full.  I had download problems with pfBlockerNG, too, but at least I was able to uninstall that.

    Suricata is broken and can’t be uninstalled, with the following error:

    Warning: require(/usr/local/pkg/suricata/suricata_defs.inc): failed to open stream: No such file or directory in /usr/local/pkg/suricata/suricata.inc on line 47 Fatal error: require(): Failed opening required '/usr/local/pkg/suricata/suricata_defs.inc' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg') in /usr/local/pkg/suricata/suricata.inc on line 47

    I could reinstall pfSense, but I’d like to learn a bit by fixing this.  The underlying problem is that the two different pfSense installations I have are experiencing package and/or file download failures.  They are both 2.2.4-RELEASE (one full, and one nanobsd) and connect to two different ports on the same ISP router.  I just downloaded a 335 MB photo-editing application update, which worked fine.

    Please advise.


  • Moderator

    Not sure why the packages are failing to download… But try the following command from the shell or command prompt:

    fetch -o /usr/local/pkg/suricata/suricata_defs.inc "https://packages.pfsense.org/packages/config/suricata/suricata_defs.inc"
    

    This will download the missing file to the correct path… Then try an un-install and see if that works...

    The XML manifest file for the package is here:

    https://github.com/pfsense/pfsense-packages/blob/master/config/suricata/suricata.xml
    


  • That worked.  I was able to delete the Suricata package.  I'm left with what's causing my package downloads to fail, but will create a different topic for that after a 7 GB CentOS download completes in a few hours, if that is successful.

    Thank you!