Balanceo de carga 2 Wan Packet loss & high Latency no funciona bien



  • Buenas a todos

    Hace unos dias configure un balanceo de carga con 2 wan, la configuracion que quiero es un balanceo donde las dos wan sean del mismo tier en mi caso tier 2 para que utilice las dos por igual y la configuracion que le puse es el de packet loss y high latency, el caso es que lo configure funcionaba y de la noche a la mañana dejo de funcionar y solo dirigia el trafico en 1 wan actuando como si fuese un failover sin estar configurado como failover por que hice la prueba de desconectar el wan donde dirigia el trafico y me lo paso al otro wan asi deduciendo que hacia failover pero no es lo que quiero ni como esta configurado, voy a pasar capturas de pantalla para que puedan ver como lo tengo configurado.

    Destacar que la configuracion que quiero es utilizar las 2 wan al mismo tiempo no quiero failover.

    Configuracion interficie Wan Principal:
    http://i.imgur.com/cRrKLxX.png

    Configuracion segunda Wan:
    http://prntscr.com/8gjznx

    Configuracion Lan:
    http://prntscr.com/8gjzuf

    Configuracion Gateways:
    http://prntscr.com/8gjzzq

    Configuracion del balanceo:
    http://prntscr.com/8gk082
    http://prntscr.com/8gk0d4

    Configuracion Firewall Rules:
    Ebrecom: http://prntscr.com/8gk0je

    Lan: http://prntscr.com/8gk0p8 Configuracion de la Lan: http://prntscr.com/8gk0z8

    Ebretic: http://prntscr.com/8gk13y

    Con todo esto el balanceo tendria que funcionar pero no funciona en absoluto, a ver si alguien me puede ayudar por que estoy provando el pfsense para hacer un balanceador de carga bastante grande para una Lan Party y solo veo que problemas



  • Vale ya encontre el problema pero no entiendo el por que a ver si alguien puede contestarme a la duda, desactivando lo que esta en gris en esta imagen: http://prntscr.com/8gkgdw ya ha balanceado como roud robin que es como queria, ahora bienen dos  preguntas:

    Las dos conexiones que tengo son conexiones de wisp y debido a que aqui en mi zona hay mucha interferencia en la banda de 5ghz las conexiones fluctuan mucho hablamos que fluctuan de 10 a 50 megas las dos(son de distinto proveedor cada una), entonces al hacer un balanceo por roud robin entiendo que el peso en cada WAN tendria que estar compensado para que la que va mas rapida no se desaproveche ancho de banda y la que va mas lenta no se cargue con exceso, el caso es saber si hay alguna configuracion para que esto lo pueda hacer pfsense de forma automatica segun el estado de la conexion wan en ese momento, lo digo por que al ver que fluctua tanto no puedo marcarle un peso de 2 o de 1



  • Esta mal el orden de las reglas. Te sugiero que leas algo de la documntacion básica que viene en el área correspondiente.



  • En system gateways y luego en Weight de la interface puedes darle  el peso que deseas que tenga en base al ancho de banda y con eso podrias pasar mas trafico a uno que a otro.

    suerte



  • Si pero por ejemplo el connectify dispatch que es otro programa para balancear en windows te permite hacer un roud robin segun la metrica de la conexion en ese momento, mira adjunto una captura para poder ver de que hablo:

    Hace el Roud Robin segun estabilidad de conexion y latencia, hace un test automaticamente cada pocos X segundos, en cambio me parece muy extraño que pfsense no tenga ese tipo de distribucion de pesos automatico por lo que veo va de 1 al 2, 3, 4 segun el peso que quieras distribuir, no hay alguna forma de que esa distribucion sea automatica en pfsense?

    Luego si me puedes dar una pista de como arreglar la regla esa, me leido toda la documentacion que hay en el top del foro donde dice DOCUMENTACION en mayusculas, no veo el error creeme a veces cuando estas metido con algo lo tienes delante las narices y no lo ves…



  • Hasta donde se no hay algo como lo que mencionas , en una pc puedes ser relativamente sencillo hacerlo pero en un firewall de este tipo no es tan "inteligente" el ruteo.

    Puedes dar prioridad según el porcentaje de perdida que tenga el enlace pero no por que tan eficiente parezca ser el mismo.  No se la verdad como es que no haga el programa que mencionas y en base a que haga las mediciones .



  • Bueno pues dicho esto ya configurare los pesos como pueda, lo que me dijiste que estaba mal en las reglas que es? he mirado toda la documentacion respecto a eso y no lo veo…



  • Vi que ya la arreglaste.  Tenías primero una que tenía precede ncia sobre lo que querias hacer.



  • Vale acriollo una pregunta si quiero que las peticiones web vaian solo por una de las conexiones por que al hacer el roud robin paginas como streamcloud no funcionan bien o facebook, como tendria que ser la configuracion? en las fotos no se be pero en el apartado de la red lan por encima de la conexion balanceada le especifique que el protocolo http y el https saliesen por la conexion de ebretic pero no funciono



  • La regla debe de ir delante de las reglas que balancean para que tengan precedencia



  • vale gracias por la aclaracion acriollo


Log in to reply