Netbios over OpenVPN



  • I've got two pfsense boxes successfully connected on a site-to-site, I have a small problem in that I am unable to ping netbios names, I cannot see an option under the server or client side to enable this, it probably a very simple fix but can anyone advise?


  • Banned

    @spies:

    I cannot see an option under the server or client side to enable this

    Get a pair of glasses?



  • @doktornotor:

    Get a pair of glasses?

    you should work on your inflection



  • @doktornotor:

    @spies:

    I cannot see an option under the server or client side to enable this

    Get a pair of glasses?

    I'm doing a site to site VPN, I don't have that option.


  • LAYER 8 Global Moderator

    "I am unable to ping netbios names"

    What does that have to do with the setting of enable netbios over tcp - which is just the setting given to the openvpn interface via dhcp when it connects to the server..  In a site to site you don't have any vpn clients to give this setting too.

    As to pinging via netbios name - how do you expect your clients to resolve these names?  Are you using wins server?  Broadcasting for them sure is not going to work over a site to site vpn with different networks on each side.. You would have to have just 1 extended broadcast domain with same network on both sides if your wanting to broadcast for names.

    If you want to use netbios names to resolve use a wins server that has the entries you want in them.. Or just do like normal people and use DNS!!  And make sure dns your using has entries for hosts on both sides of your S2S..

    the netbios setting over tcp is not the root of not resolving netbios names..




  • @johnpoz:

    the netbios setting over tcp is not the root of not resolving netbios names..

    Correct. Setup your DNS correctly. NetBIOS hasn't been the preferred option since Windows 9x/NT 4.



  • Also adjust your Windows box's firewall to allow pings from outside their subnets.


Log in to reply