[Temp Fix] OpenVPN maxing out at 50Mbps on a 150Mbps line (my CPU?)

  • ~Update at the End~

    I recently upgraded from DSL (10Mbs/5Mbs) to cable (150Mbs/20Mbs).  Now I think my box cant handle my new configuration.

    Pfsense is set up as a client to connect to my VPN provider so I can route all or specific traffic on my network through it rather than trying to connect multiple devices all the time.  This setup works and has worked but now with the faster connection OpenVPN/Pfsense is maxing out at 50Mbs.  I know it has something to do with my pfsense box because when I use Openvpn client from my windows machine I get the 120Mbs over my VPN but when the traffic from my windows machine uses pfsense as the client to route traffic to the VPN it maxes out 50Mbs.

    The thing I noticed most was when I setup multiple OpenVPN connections to differnt VPN providers and then setup my pfsense box to use those connections as a gateway group they always add up to or around 50Mbps.

    Box Specs:


    2.2.4-RELEASE (amd64)
    Intel(R) Celeron(R) CPU J1900 @ 1.99GHz
    Current: 1992 MHz, Max: 1993 MHz
    4 CPUs: 1 package(s) x 4 core(s)
    7859 MB RAM
    All NICs 1000baseT <full-duplex>VPN:
    Encryption algorithm: AES-256-CBC
    Auth Digest Algorithm: RSA-SHA256

    Thanks for any help you can provide,


    So I moved the box to a esxi server and ran the same settings and still around 50Mbps.  So now I know it's not my hardware. So I kept digging and came across a few post on the forums with the same problem but different wording.


    I pulled out my old copy of pfsense 2.1.5 copied the same set up on the virtual box and 150Mbps…

    So there is some setting in pfsense 2.2.4 that is not right?  Is this is bug I'm not aware of and just spamming the forums with another redundant post?  For now I will just keep back on 2.1.5 for now.</full-duplex>

  • i also have a J1900 CPU and get full 100MBit VPN speed on my 100MBit line (pfsense 2.2.2). so yes, it seems that possibly your version has some kind of bug that slows down the connection.

Log in to reply