Problemi con DHCP Relay



  • Salve a tutto il forum, vorrei esporre il mio problema. Sto facendo delle prove con delle VM ed ho creato questa struttura di rete:

    3 Switch virtuali WAN-LAN1-LAN2

    1 DC con NIC 192.168.0.1/24 GW 192.168.0.100 con DNS E DHCP. Su DHCP ho abilitato 3 Scopes:

    1 - 192.168.0.0/24
    2 - 172.16.0.0/16
    3 - 10.0.0.0/8
    con tutte le options abilitate

    2 - Macchina Pfsense Linux con 3 NIC con i seguenti IP: NIC1(WAN) 192.168.0.100/24 GW 192.168.0.254 - NIC2 172.16.0.100/16 NO GW - NIC3 10.0.0.100/8 NO GW. Sulla macchina linux ho attivato il DHCP Relay su NIC2 e NIC3 puntando al server 192.168.0.1. Poi ho creato due VM client ognuna collegata ad un diverso switch (LAN1-LAN2) ma ho problemi a far navigare contemporaneamente le due reti. Solo la VM collegata alla rete 172.16.0.0/16 (LAN1) riescono ad andare su Internet, mentre la VM collegata all'altra 10.0.0.0/8 (LAN2) non naviga nonostante riceva il corretto indirizzo IP da DHCP. Dove sbaglio? Potreste aiutarmi. Grazie anticpatamente.

    Saluti



  • Buongiorno.

    Mi accodo anche io al problema esponendo un problema molto simile..

    Da un salone remoto con subnet 192.168.81.0/24 collegato con PFSENSE-OPENVPN al entro stella, devo far funzionare il DHCP RELAY verso il server 192.168.80.xxx/32 fisicamente locato al centro stella.

    In pratica la rete 81.0/24 deve fare relay sul server 192.168.80.xxx/32, funzione che ad esempio permette il Cisco tramite IPHELPER.

    Ho provato a configurare il DHCP RELAY di PFSENSE ma non funziona se non viene dichiarato un indirizzo sulla stessa subnet..

    Come posso risolvere?



  • Tornando al mio problema, sembra che il NAT funzioni solo su una NIC.