Inoltro IP Pubblico a privato mask 255.255.0.0



  • Ciao a tutti. La mia domanda vi sembrerà cretina, ma non riesco ad uscirne.

    Ho un centralino VOIP che tramite ip pubblici si collega ad un altro centralino VOIP utilizzando PFSENSE per far comunicare fra di loro gli interni di due sedi.

    Da quando ho modificato la subnet mask sul centralino da 255.255.255.0 a 255.255.0.0 non riesco a farli dialogare.

    Ho creato il virtual Ip xxx.xxx.xxx.xxx/29, ho creato il port forward con regola sul firewall ma niente da fare.

    Qualche anima pia mi aiuta?

    Grazie in anticipo.

    Update 21/09 - 15.40 Ho impostato sul pc un indirizzo 172.16.5.xxx e maschera 255.255.255.0 e ho visto che comunque raggiungo il gateway 172.16.0.254. Appena riesco metto 255.255.255.0 sul centralino che ha come indirizzo su eth0 172.16.3.xxx e su eth1 172.16.3.yyy, se tanto mi da tanto dovrebbe funzionare.

    Vi scriverò dopo.

    Grazie ciao.



  • Se è un Asterisk o similare nel file nat.conf ci metti gli indirizzi della tua rete



  • Si. E' un Asterisk, ma non ho accesso alla riga di comando… E' configurabile solo via web...

    Il problema comunque non era lui o la subnet mask... Ma Pfsense che si teneva "in canna" dei NAT vecchi e faceva confusione...

    Facendo delle prove con vari reset state ho risolto.

    Ho notato che (sempre facendo delle prove) modificando il nat outbound da automatic a Manual e ripassando in automatic mi restano le regole in memoria, anche se sono grigie e quindi in teoria disattivate... La domanda è che non so se posso eliminarle o se poi me le elimina anche dall'automatic...

    Magari se può essere utile per spiegarmi o per correggere qualche baco domani posto uno screen shot (adesso vado a casa)...

    Dopo questi 3 giorni il baco ce l'ho in testa... Ah cosa importante la mia release è la 2.2.2 Di Apr 13 2015 non ho aggiornato.

    Ciao e grazie a tutti.


Log in to reply