Wifi bridged with Lan



  • I followed these instructions to bridge my wifi to my lan connection.

    https://www.artooro.com/2015/02/20/how-to-configure-wi-fi-in-pfsense/

    At first it appeared that everything worked perfect. But now I notice that the computers on the lan are acting as if I was unplugging the cat5 and plugging it back in constantly.

    Attached is a picture of the log file. Can anyone help?

    I'm running pfsense 2.1 only because I can not get ipsec to work in the current version

    Walter


  • Banned

    @whaase:

    I followed these instructions to bridge my wifi to my lan connection.

    Why?  ::)

    Plus it clearly wasn't followed correctly either, see the complaints about static IP still assigned to LAN so it now conflicts with the bridge…

    Not to mention, the howto is missing setting the required system tunables so that you could configure the firewall rules on the assigned bridged interface, instead of members.



  • Clearly I'm missing something.

    My LAN port is now bridged, and configured with a static ip and DHCP is enabled

    My new "LAN_PORT" that is set for my second adapter going to the LAN is not configured for anything for the ipv4 or 6.

    Just as the article describes and shows in his pictures.

    I looked up the System tuntables and have made those changes.

    net.link.bridge.pfil_member Set to 0 to disable filtering on the incoming and outgoing member interfaces. 0

    net.link.bridge.pfil_bridge Set to 1 to enable filtering on the bridge interface 1

    Can you direct me as to what I'm not doing right?

    Thanks, Walter


  • Banned

    Before debugging anything else (we still do not know why are you bridging in the first place) - did you reboot the box?



  • This box is going in a remote office. Its connected via a VPN back to the main office's Sonicwall.

    They have some computers on wired and wireless. I want them to all be on the same 172.16.5.0 network

    I have rebooted several times.

    I've been googling and reading posts here. It seems like it should be correct according to everything I've read (They all say the same thing).

    I'm stumped


  • Banned

    @whaase:

    I want them to all be on the same 172.16.5.0 network

    And again? Why? Why are you causing yourself this totally pointless trouble? The packets route just perfectly fine between local interfaces. There's no need to bridge them. Bridging insecure wifi with LAN is a bad idea anyway.



  • I'm trying to avoid a routing nightmare using a different ip range for wireless

    I suppose I could try, but time is not on my side with this one. Just doesn't seem like it should be this complicated


  • Banned

    What nightmare? It works out of the box!



  • My lan traffic, 172.16.5.0 can not connect to my wlan traffic 172.16.17.0

    Walter


  • Banned

    Perhaps, put an allow firewall rule on the other interface? (There's none by default.) Look at the firewall logs.



  • I gave up the fight. I tried firewall rules and googled for hours. I'm thinking my wifi card may not be supported properly.

    So I ended up using a old wifi router as a AP. Worked very good and did exactly what I needed. I wish i could get it in all one box, but, its working.

    Thanks for the help and ideas

    Walter



  • Don't give up, If you have an ATH0 chances are it is fine. What exact Atheros module are you using?  Internal PCIe card or MiniPCIe Module? Brand? If generic -Atheros model# if you can find it. ie. AR5BXB112 is an example for generic laptop module.


Log in to reply