HTTP requests fail after upgrade to 2.2.4



  • I have a Pfsense box running for over an year or so and has been upgrading every now and then.
    Today I upgraded my Pfsense box to 2.2.4 (I presume my version before upgrade was 2.2.1 or 2.2.2 ).
    I run squid 4.3.9 and squidGuard 1.9.15 for webfiltering.
    After the upgrade HTTP requests are not working but HTTPS request are working fine.
    Please the screenshot attached.

    These are some of the questions I have
    Can I reinstall squid and squidguard without loosing my configuration.
    Should I downgrade back to older version?

    Thanks in advance for the help.
    Ahmed



  • First thing to try would be to either stop & restart squid service, or reboot the box.



  • @KOM I did restart the box several times.
    Did restart the service from the services tab.
    I managed to fixed it.
    squidguard blacklist database was corrupt and was refusing to start.
    Evethough it says squidguard service was started it actually wasn't.
    I rebuild the blacklist database and viola it is fixed.



  • squidGuard isn't really a service.  It's an application that gets called by squid for every URL that squid processes, so the service status thingy for squidGuard is useless.


Log in to reply