Squid and Squid 3



  • hi all
    I'm a new user and read through a few posts but couldn't resolve my issue
    running pfsense 2.2.4-RELEASE  (amd64)
    built on Sat Jul 25 19:57:37 CDT 2015  FreeBSD 10.1-RELEASE-p15

    Squid 3  beta 0.3.4 platform: 2.2

    I first installed Squid and Dansguardian and it all worked for a few days and then I could not reach outside my network. Sorry I forget the error message Squid was giving me but something about DNs Forwarder or resolver error.

    anyway, I removed those packages and tried Squid 3 only.
    When I install and configure it I cannot browse outside my network
    I get the follow error for example of me trying to reach google.com

    The following error was encountered while trying to retrieve the URL: http://www.google.com/

    Unable to forward this request at this time.

    This request could not be forwarded to the origin server or to any parent caches.

    Some possible problems are:
    •An Internet connection needed to access this domains origin servers may be down.
    •All configured parent caches may be currently unreachable.
    •The administrator may not allow this cache to make direct connections to origin servers



  • After you install squid, you need to either reboot the server or restart the squid service.  It seems to block all web access until you bounce it.


Log in to reply