VoIP Telekom Umstellung



  • Hallo,

    ich habe noch ein paar Probleme:

    • Vor der Umstellungen hatte ich 49,8 MBit/s im Download jetzt nur noch 31 MBit/s. Irgendeine Idee, was das sein kann?
    • Die Telefonie funktioniert manchmal nicht. Wenn ich versuche nach draußen zu wählen oder angerufen zu werden, ist die Leitung einfach tot (kein besetzt Zeichen oder etwas in der Art).

    Irgendeine Idee, was das Problem sein könnte?

    Danke und Gruß.



  • Mit dem Download wüsste ich nicht was es damit zu tun haben soll.

    Schau mal ob du irgendwie keep alive für SIP (NAT Keep Alive) einstellen kannst in der Fritz Box bei meinem IP Phone kann ich das nämlich. Das hällt die Firewall offen.



  • Alles klar, evtl. stimmt auch etwas bei der Telekom noch nicht.
    Ich werde es dennoch testen. Danke!  :)



  • Alles klar, evtl. stimmt auch etwas bei der Telekom noch nicht.

    Wegen der Downloadgeschwindigkeit vielleicht ja heißt ja immer bis zu  ;)

    Die Telefonie funktioniert manchmal nicht. Wenn ich versuche nach draußen zu wählen oder angerufen zu werden, ist die Leitung einfach tot (kein besetzt Zeichen oder etwas in der Art).

    das meinte ich mit dem Keep Alive das ist eher etwas bei dir nicht bei der Telekom.
    Wenn du langs nichts machst geht die Firewall wieder zu daher sollte man Keep Alive einstellen. Sollte auch gehen

    Beispiel: FRITZ!Box - Aktivierung "NAT Keep alive"

    Falls Sie unregelmässig eingehende Anrufe erhalten, kontrollieren Sie die Einstellungen Ihres Routers bezüglich "NAT Keep Alive". Am Beispiel der FRITZ!Box finden Sie dies unter ->Telefonie -> Internettelefonie -> Erweiterte Einstellungen. Sie müssen die "Portweiterleitung des Internet-Routers für Internettelefonie aktiv halten" aktivieren.



  • Beispiel: FRITZ!Box - Aktivierung "NAT Keep alive"

    Danke für die genaue Beschreibung! :-)
    Ich teste es heute Abend gleich.



  • Abend zusammen,

    diese Einstellungen waren schon gesetzt.

    ![Screenshot from 2015-10-12 20:29:44.png](/public/imported_attachments/1/Screenshot from 2015-10-12 20:29:44.png)
    ![Screenshot from 2015-10-12 20:29:44.png_thumb](/public/imported_attachments/1/Screenshot from 2015-10-12 20:29:44.png_thumb)



  • 5 Minuten sind zu lange
    Oben stellst du ja ein das die Firewall bei UDP 30 Sekunden offen bleiben soll.
    Wie weit kannst du da denn runter gehen? Bei meinem Phone daheim habe ich 20 Sekunden eingestellt.
    Du solltest unter den 30 Sekunden bleiben wenn möglich.
    Die 30 Sekunden in der Firewall höhrer zu stellen macht das Ganze wieder etwas unsicherer daher schau mal was in der Fritz Box geht.



  • Morgen,

    danke für den Tip.
    Könntest du mir bitte kurz erklären was ich hier eigenltich genau einstelle bzw was es mit der Zeitdauert auf sich hat.

    Danke :-)



  • Die Firewall ist Dynamisch sprich wenn ein Paket raus geht lässt sie die Antwort auf dieses Paket automatisch zu.
    Bei TCP Gibt es einen Anfang und ein Ende (Syn und Fin).
    Bei UDP gibt es das nicht also macht die Firewall auf und wenn nach einer bestimmten Zeit (Bei dir in der PfSense 30 Sekunden) kein Paket mehr kommt macht sie wieder zu.
    Mit dem Keep Alive in der Fritz Box kann man dafür sorgen das in einem bestimmten Abstand (bei dir in der Frit Box alle 5 Minuten) ein UDP Paket geschickt wird welches die Firewall offen hält.
    Da bei dir alle 5 Minuten ein UDP Paket geschickt wird und die Firewall aber schon nach 30 Sekunden wieder zu macht, werden die ankommenden Pakete (z.B. eingehende Anruf) geblockt.
    Daher solltest du in der Fritz Box nicht 5 Minuten einstellen sondern 30 Sekunden oder weniger.



  • Alles klar :-)
    Habe es verstanden.
    Many thanks ;-)



  • Ich habe jetzt die Zeit auf der Fritzbox auf 30 Sekunden gestellt (weiter runter kann man sie nicht stellen).
    Dies gilt ebenfalls für die Firewall. Hier steht es auch auf 30 Sekunden.
    Hoffe es wird jetzt besser.

    Danke & Gruß



  • Leider besteht das Problem immer noch :-(
    Hat jemand noch eine Idee, was man machen kann?



  • In dem Telefonlog der Fritzbox finde ich immer wieder diesen Eintrag:

    Internettelefonie mit xxxxxxxxxxx@tel.t-online.de über tel.t-online.de war nicht erfolgreich. Ursache: (408)



  • Ich hatte mal das Problem das wenn sich mein WAN IP geändert hat das die States irgenwie hängen geblieben sind.
    https://redmine.pfsense.org/issues/1629
    Sprich ich hatte einen Trace gemacht (unter Diagnostics: Packet Capture) und habe da gesehen das die PfSense Invites an die Telekom mit einer alten WAN IP schickt.
    Ich hatte aktuell auf dem WAN Interface eine andere IP als in dem Trace stand.

    War es ein ausgehendes Gespräch?
    Könntest mal die States reseten und schauen ob es dann wieder geht.
    Oder du dich mit Wireshark auskennst könntest du das ja mal mittracen (unter Diagnostics: Packet Capture) und schauen ob das bei dir auch so ist.



  • Das Problem ist sehr komisch.
    Ich versuche z.B. nach draußen zu wählen –> Die Leitung ist wie tot, sprich es klingelt nicht.
    Versuche ich es direkt im Anschluss nochmal klappt es.
    In der Zeit hat sich auch nicht die IP auf der WAN Seite geändert oder sonstiges.

    War es ein ausgehendes Gespräch?
    Ja.
    Das Problem tritt aber auch bei eingehenden Gesprächen auf.

    Könntest mal die States reseten und schauen ob es dann wieder geht.
    Sorry, aber verstehe nicht was du damit meinst :-)



  • Wenn es nicht geht und direkt danach geht nützt es auch nichts die States zu reseten.

    ein 408 bedeutet Timeout also das die Gegenstelle nicht reagiert.

    Dann müsste man echt mal mittracen und schauen wie die SIP Invites aussehen aber das ist nicht so einfach wenn man nicht weiß wie man Wiresharktrace lesen soll.
    Machen kann man die recht einfach unter Diagnostics: Packet Capture aber wenn man es nicht lesen kann nützt es leider nicht viel.



  • Ich kann in der Fritzbox sehen, dass die Antwortzeiten sehr hoch sind.
    Teilweise >3000ms.

    Hast du eine Idee, was man noch Einstellen kann um das Problem in den Griff zu bekommen?

    ![Screenshot from 2015-10-14 13:03:00.png](/public/imported_attachments/1/Screenshot from 2015-10-14 13:03:00.png)
    ![Screenshot from 2015-10-14 13:03:00.png_thumb](/public/imported_attachments/1/Screenshot from 2015-10-14 13:03:00.png_thumb)



  • die 3000 ms besziehen sich auf die Gesprächsdauer wenn ich das richtig lese das ist nicht schlimm

    Jitte, Paketloss und Verzögerung der Sprachpakete passen das ist nicht das Problem.
    Sieht aber so aus als hättest du bei ausgehenden Gesprächen einseitige Verständigung weil in die eine Richtung gar keine Pakete gehen.

    Prüf doch noch mal deine NAT Einstellungen ist da alles richtig gepflegt also stimmt der Alisa FritzBox steckt dahinter die richtige IP?
    Weil es scheint mir so als wenn da etwas nicht stimmt.



  • Ich habe mal beide Screenshots angehängt.

    Was ich so komisch finde ist, das es manchmal geht und dann mal wieder nicht.
    Als würde irgendwas in einen sleepmode gehen und dann erst wieder aufwachen.






  • genau das sollte ja mit dem Keepalive verhindert werden.
    Wenn du bei der FitzBox nur 30 Sekunden einstellen kannst stellt doch mal die UDP Timeouts höher ein mal auf 60 und schau ob es besser wird.
    Wenn es besser wird dann versuchen so weit runter wie möglich zu gehen.



  • Ist auch nicht besser.
    Was spricht dagegen, die Zeit auf der pfSense hochzuseten.

    Verstehe ich das richtig, dass die pfSense den Port nach 30 Sekunden wieder schließt, wenn kein Traffic über ihn läuft?



  • Die PfSense macht wieder zu damit kein andere über diese Ports etwas einschleusen kann. Geht ja um die Eingehende Richtung und da sollte ja alles dicht sein.
    Nach Außen kannst du immer aber die Antwort muss ja auch durch kommen

    Ich meinte ja auch die UDP Timeouts auf der PfSense nicht auf der FritzBox da so klein lassen wie möglich.
    Und der der PfSense dann höher stellen und testen



  • Alles klar.  :-)
    Habe es auf 60 Sek. gestellt.
    Ich teste es mal wieder.

    Danke für die tolle Hilfe :-)



  • Ich habe nun das Problem, dass ich nicht mehr angerufen werden kann.
    Nach draußen wählen geht aber noch.

    Hat jemand eine Idee was das sein kann?



  • genau das sollte mit dem Keep Alive eigentlich verhindert werden das du nicht angerufen werden kannst.

    Wenn du angerufen wirst und es geht nicht taucht da etwas im Firewall log auf?



  • Hallo Hackel,

    funktioniert es jetzt bei Dir?

    Ich habe das gleiche Phänomen, jedoch ist es bei mir nicht die Telekom, sondern HTP ein lokaler Anbieter. Habe auch schon alle möglichen Einstellungen probiert, aber leider hat nichts geholfen. Manchmal funktioniert alles un dann wieder nichts. Bin am verzweifeln.

    Achso, auch bei mir ist es eine Fritzbox hinter einer pfSense. Ein Unterschied ist vielleicht, dass ich das WAN und das LAN der Fritzbox über unterschiedliche VLAN trenne.

    Wäre schön, wenn Du mir bescheid geben könntest, ob es jetzt bei Dir funktioniert.

    Herbert



  • Hallo Herbert,

    nein, leider funktioniert es nicht.
    Ich habe aktuell auch keine Idee, was ich noch testen kann. :-(
    Bin etwas verzweifelt. :-(



  • Hallo Hackel,

    gerade habe ich das Problem lösen können. Bei mir funktioniert die Verbindung, wenn die Fritzbox nach folgender Anleitung auf den internen Netzwerkverkehr umstelle: http://avm.de/service/fritzbox/fritzbox-7390/wissensdatenbank/publication/show/106_FRITZ-Box-fuer-Betrieb-mit-anderem-Router-z-B-IAD-einrichten/

    Dann erreiche ich die Fritzbox zwar nur noch über den LAN1, aber die Telefonie funktioniert ohne Probleme!!!

    Hoffe es hilft Dir,

    Herbert



  • Hallo Herbert,

    willst du vielleicht ein paar Screenshots von deinen Einstellungen machen, was du genau alles eingetragen hast.
    Dann gibt es hier im Forum eine komplette Anleitung für die VoIP-Umstellung.

    Die Leute, die nach uns umgestellt werden, sind bestimmt dankbar :-)

    Gruß



  • Hallo Herbert,

    bei mir funktioniert es mit der Anleitung auch leider nicht (so hatte ich es vorher auch alles eingetellt und jetzt nochmal auf Werkszustand zurückgesetzt und neu versucht).

    Im Log taucht immer wieder dieser Fehler auf:

    Internettelefonie mit xxxxxxxxxxxxxxx@tel.t-online.de über tel.t-online.de war nicht erfolgreich. Ursache: (408)



  • @flix87: Sorry für meine späte Anwort.

    Zu deiner Frage…:
    Wenn du angerufen wirst und es geht nicht taucht da etwas im Firewall log auf?
    Nein, das Firewalllog sieht gut aus. also es wird nichts geblockt, wenn das Anrufen mal wieder nicht funktioniert.



  • Dual WAN oder so hast du nicht im Einsatz oder?

    Weil so langsam weiß ich auch nicht mehr weiter bei mir klappt das so mit den Einstellungen.



  • Nein, habe kein Dual WAN.
    Ich auch nicht :-(



  • dann helfen vielleicht wirklich nur noch Wireshartraces auf der PfSense vielleicht sieht man da was.



  • Hallo zusammen,

    kann es evtl sein, dass noch mehr Ports freigegeben werden müssen?

    Auf der Firtzboxseite finde ich diese:
    http://avm.de/service/fritzbox/fritzbox-7490/wissensdatenbank/publication/show/777_Fehlermeldung-Die-Portfreigabe-kann-nicht-erstellt-oder-aktiviert-werden/

    TCP- und UDP-Port 5060 (Internettelefonie)
    UDP-Ports 7078-7109 (Internettelefonie)

    5060 habe ich ja bereits eingerichtet.

    Gruß
    Tobias



  • Hallo,

    habe auch seit zwei Wochen auf ALL-IP der Telekom umgestellt und folgende Konstellation erfolgreich am laufen:

    Fritzbox 7170 als IP-Client hinter der Pfsense (PfSense wählt sich über ein vorgeschaltetes Allnet-Modem ein).
    Ich habe die Telefonnummern auf der FB mit STUN-Server eingerichtet und das Häckchen bei Verbindung aktiv halten (30 Sekunden) gesetzt.
    Auf der PFsense habe ich nur Outbound-Nat auf Hybrid gestellt und eine Regel mit Static-Port eingerichtet. Sonst nichts…

    Auch nach einem Reconnect habe ich bis jetzt keinerlei Probleme feststellen können. Ich hoffe das bleibt so  :)

    Viele Grüße

    Tom



  • Hallo Tom,

    danke für deine Antwort.
    Könntest du bitte nochmal Schritt für Schritt beschreiben, was du an der pfSense und der FB einstellt hast und ggf. auch Screenshots dazu machen.
    Bin echt am verzweifeln.

    Fritzbox 7170 als IP-Client hinter der Pfsense (PfSense wählt sich über ein vorgeschaltetes Allnet-Modem ein).
    Ich habe eine FB 7490 die auch als IP-Client hier der pfSense hängt (die pfSense macht auch die Einwahl über ein vergeschaltetes Zyxel Modem).

    Ich habe die Telefonnummern auf der FB mit STUN-Server eingerichtet und das Häckchen bei Verbindung aktiv halten (30 Sekunden) gesetzt.
    Habe ich auch so gemacht.



  • Hallo Tobias,

    bin gerade auf den thread gestoßen. Ich hatte eine Fritzbox so im Einsatz. Auf die Gefahr hin Dich völlig zu verwirren – ich hatte dafür eine Beschreibung in dem folgenden Post geschrieben:

    https://forum.pfsense.org/index.php?topic=85517.msg522370#msg522370

    Da gibt es auch Bilder.

    Beschreibung angepaßt, Bild-Nummer aus dem Original-Post:

    1. Feste IP für die FB festlegen, z.B. 172.27.2.61, Alias "FB" (in den Bildern verwende ich "C430IP")

    2. Unter Firewall: NAT: Outbound eine Regel auf dem WAN-Interface, Source = 172.27.2.61/32, NAT Address = WAN address, static port = yes.

    Die restlichen Regeln werden weiterhin automatisch verwaltet (hybrid).

    Siehe Bild 1.

    3. Unter Firewall: NAT: Port Forward zwei Einträge:

    If=WAN, Proto=UDP, Src./Src ports = any, Dest. addr = WAN address, Dest. ports = 5060, NAT IP = 172.27.2.61
    If=WAN, Proto=UDP, Src./Src ports = any, Dest. addr = WAN address, Dest. ports = 7078-7109, NAT IP = 172.27.2.61

    Siehe Bild 2 und 4 (meine Ports sind anders ...)

    Die notwendigen Regeln auf dem WAN interface werden automatisch mit angelegt, siehe Bild 3.

    4. Auf der Firewall muß ausgehender Traffic erlaubt werden (wenn nicht ohnehin aller ausgehender traffic bereits erlaubt ist):

    Proto = IPv4 TCP/UDP, Source = 172.27.2.61, Dest port = 5060
    Proto = IPv4 UDP, Source = 172.27.2.61, Source Ports = 7078-7109, Dest / port = any

    Siehe Bild 4.

    Du brauchst KEIN STUN! Bei mir hatte es völlig ausgereicht, einen Keep-Alive in der FB zu konfigurieren.

    -flo-



  • Hallo Flo,

    habe es jetzt mal so geändert.
    Bin mal gespannt.

    Werde ich in einer Woche melden, ob alles geklappt hat. :-)

    Danke schon einmal für deine Hilfe! :-)



  • Hallo  zusammen,

    habe es jetzt mal längere Zeit getestet.
    Leider bestehen die Probleme noch :-(

    Hat jemand noch irgendeine idee?

    Gruß


Log in to reply