Squid3 0.3.7 with pfsense 2.2.4



  • I have been trying for 3 days to get squid3 to work with 2.2.4.  I have been using 2.1.5, but decided it was time to upgrade.

    I am using a DQ77KB motherboard with i5-3470, 8gb of ram, and a 64gb msata hard drive.

    I first upgraded the firmware and packages via the GUI, squid3 would not start.

    I then tried a new install and a restore from a config.xml file via the GUI.

    I have now done a new install and tried just loading squid3 from the GUI.  When I try to start squid3 in transparent mode, I get the following error:

    The following input errors were detected:
    The field Log Store Directory is required.
    Log location must start with a / character.
    Configured log location directory is not valid.

    I've tried searching, but have not found a solution.  Any thoughts on what I need to do to get it to work, and why doing a new install with just the one package results in an error?

    Thanks in advance for the help.

    Kevin


  • Banned

    Which part of those hints to configure things properly is unclear? Do not leave the field empty and put some /valid/location/in/there. Such as /var/squid/logs perhaps. Upgrade to 0.3.8, hopefully it solves your  "issue".



  • Maybe I'm crazy, but was /var/squid/logs not the default previously?  Why would he have to type it in manually?



  • Thanks for the guidance.  Just keying in the path didn't work.  I had to check the box to enable logging and key-in the path and it started.

    I am now in process or restoring my configuration and see if all works.

    Thanks,
    Kevin


  • Banned

    Perhaps because upgrade from some superbroken 2.1.x Squid versions just won't work? (Same goes for doing a fresh install and importing the package configuration.)

    On that note, the good thing about 0.3.8+ is that - if you at least manage to install it and uninstall it straight away with enabling the "Keep Settings" thing, it should give you a Squid-free config.xml without any manual messing and leftovers from god knows how many old Squid variants and versions.


Log in to reply