OpenVPN OSX nightmare



  • I am able to connect using Viscosity on OSX and can PING the LAN interface IP but am unable to connect to any internal resources at all.

    Using OpenVPN on Windows works fine so I am assuming OpenVPN setup is correct.  How to get OSX to ba able to access resources on LAN???

    Pain in the Butt!!!



  • I' ve horked with mac os x yosemite and mac osx x 10.6, but I've used tunnelblick, and it works fine.

    Try with tunnelblick, in "users export" choose the option "Files only" and with double click on the .ovpn file, it will add the client to the tunnelblick menu.



  • Yeah I tried tunnelblick and I get the same result.  Also that app tends to disconnect on a regular basis but Viscosity stayed connected.

    Maybe mobile ipsec client would be better and more reliable. :-(  Spent so many hours with no resolution!

    Crazy it work in Windows but not OSX.


  • LAYER 8 Netgate

    I use Viscosity into pfSense 2.2.4 OpenVPN literally all day every day.  It's pretty much flawless as far as I'm concerned.

    You have something configured wrong.  Stop blaming Viscosity/OS X and start looking for what you did wrong.



  • And a error log from the client would be useful  ;)



  • Not blaming.  Just stating that all I have tried so far is not working with the MAC.  PC works fine.  I am unable to ping LAN network.  Only LAN interface.



  • Are you accessing them from the same location? IE are the mac and the pc on the same network attempting to reach the VPN server.

    Is the mac being pushed the proper route to get to your remote IP range? I use Viscosity everyday connecting to multiple installs of PFsense without issue, it does work well once it is setup properly.


Log in to reply