Wpad and android



  • I've configured wpad on my pfsense box. For the life of me I cannot get it to work with my android devices. It works fine on my computers. For example, in firefox browser on computer I choose auto-detect proxy settings. It works great. Android only has manual option. Not sure if I am providing the wrong host and or port.  What exactly am I specifying here?

    My setup is as follows:

    wpad.dat/proxy.pac/wpad.da is server from web server on 192.168.50.1 on port 80

    Hosts reside on 10.0.2.0/24. Squid is bound to this network address and listening on port 3128

    So in the manual options for android am I specifying the web server info or the squid info?

    I've tried both way and can't get it to work. Moreover, if I try the same on a computer host it won't work. Only thing working is choosing auto-detect settings.

    any help would be great.
    TIA


  • Banned



  • AFAIK only Lollipop 5.1.1 AOSP supports specifying an explicit PAC file per WiFi SSID. My CM 12.1 works beautifully like this. There are apps that let you use a PAC file, but they are cumbersome. Search the App Store.


Log in to reply