PFSense IPv4 Forward Problem



  • Ok, so I have this bizzare problem. I am on ubuntu 14.04LTS with vmware workstation 12. Now I have a host-only network with PFSense as the router in a VM. On a flat network model, it works without a problem. The issue begins to happen when I attempt to put more VMs INSIDE the original base VMs in a bridged networking fashion. I attempted to do an OpenStack Install and quickly found out that none of the virtualized VMs were getting any IP addresses for some reason. So I chucked vmware workstation 12 in a vm and tried to solve it. I am officially stumped. Please help? Here is a visual model of my problem: (2.2.4-RELEASE)

    WLAN
                    |
                    |
              PFSense VM (2.2.4-RELEASE)
                    |
                    |
            VMs + Host (Host-only network)
                    |
                    |
    Bridged Networking VM. <– this VM is the one that refuses to have an IPv4 assigned, but appears to have an IPv6 no problem. It should be noted that DHCP DISCOVER and DHCP OFFER are seen in the logs. But no DHCP Request. :|



  • You may try turning on promiscuous mode for the specific vswitch on which dhcp should work on. I have seen many problems with openvpn and DHCP, when promiscuous mode is denied.



  • How would I turn on promiscous mode? And I'm not using OpenVPN..



  • Hi,
    yip - no openvpn, but I have seen this kind of problem on such type of setup.

    Concerning http://sanbarrow.com/vmx/vmx-network-advanced.html you may set the parameter
    ethernet0.noPromisc = "FALSE" in your .vmx file of your vm.
    No need to say, that  you will need root-privileges.

    Also make sure, that the integrated DHCP of vmware workstation on the specific NIC is turned off :/



  • Thanks, that was the issue :)


Log in to reply