PHP Parse error in all VPN menu items



  • Hi all,

    I can't access any pages from the VPN dropdown. All return some sort of PHP parse error.

    Crash report begins.  Anonymous machine information:

    amd64
    10.1-RELEASE-p15
    FreeBSD 10.1-RELEASE-p15 #0 c5ab052(releng/10.1)-dirty: Sat Jul 25 20:20:58 CDT 2015   
    root@pfs22-amd64-builder:/usr/obj.amd64/usr/pfSensesrc/src/sys/pfSense_SMP.10

    Crash report details:

    PHP Errors:
    [05-Oct-2015 18:39:58 Europe/London] PHP Parse error:  syntax error, unexpected ')' in /usr/local/www/vpn_ipsec.php on line 274

    or:

    PHP Errors:
    [05-Oct-2015 18:47:04 Europe/London] PHP Parse error:  syntax error, unexpected '' (T_NS_SEPARATOR), expecting ']' in /usr/local/www/vpn_openvpn_server.php on line 117

    • I've not made any config changes I can think of to trigger this.

    • The OpenVPN service seem to be running properly despite this.

    • Other Web Pages seem un-affected by the problem.

    • I think the error has changed once or twice suggesting the line referenced in the files is a bit of a red herring. I've taken a look at the PHP files and they look ok.

    • I tried to reinstall the OpenVPN Export Utility but this caused the machine to reboot. I've uninstalled it but haven't tried reinstalling yet as the problem is still present.

    Please let me know if any further info would be helpful or if there's any maintenance tasks I can perform.

    Thanks in advance all,

    pfugu



  • I guess you are running 2.2.4 from the look of the 10.1-RELEASE-p15

    vpn_ipsec.php line 274 does not even have a ')' in it or near it in the version in the RELENG_2_2 branch of the GitHub pfsense repo.

    Similar for vpn_openvpn_server.php line 117 - no '' to be seen around there.

    What is in those lines and the surrounding lines on your system?

    It seems like something has corrupted some code somehow.



  • Hi Phil, thanks for checking that. It seems there was some corruption further down the file so I suspect nonsense was getting passed into the variable or something like that.

    I swapped out the disk for a new one and did a clean install. Config restored and all is working as expected now.

    Thanks again for your help.


Log in to reply