Package installation failed then worked, maybe



  • I'm running in a VM, fresh install, nothing configured. My goal was to test restoration of a config backup from 2.2.4.
    My plan was to follow the wiki suggestions for changing architecture: backup current, install fresh, install packages, restore config.

    When presented with the first wizard, I clicked through the menus to install packages.
    I installed iperf, the openvpn config downloader, and then tried to install snort.

    Snort failed at step 6 of 12 (mysql), showed an error, everything looked accurate.
    I noticed it was listed as installed, however, so I uninstalled it. That went fine, through all 12 steps and claimed it was properly uninstalled.

    Afterward, I decided to install it again so I could get the failure details and research further. When I clicked install, it installed without errors through all 12 steps. The GUI shows "FAILURE" even though all steps show "Done".

    I just clicked on "Reinstall" to see what would happen and this is the message:

    The pfSense-pkg-snort package is not installed.
    
    Deletion aborted.
    Package reinstalled.
    

    I read that some of the package installation wording/etc is broken and a known issue, but this seemed beyond just simple wording. It appeared to be accurate (first failure), then bad wording (apparent success), and finally inaccurate (package not installed, if that message can be trusted).

    If there is any further information I can provide, or steps to perform, please let me know. I'm happy to help iron out kinks and get 2.3 released.



  • I chose to remove the package and this was the result:

    Removing package…
    Checking integrity... done (0 conflicting)
    Deinstallation has been requested for the following 1 packages (of 0 packages in the universe):

    Installed packages to be REMOVED:
    pfSense-pkg-snort-3.2.8

    The operation will free 1 MiB.
    [1/1] Deinstalling pfSense-pkg-snort-3.2.8…
    [1/1] Deleting files for pfSense-pkg-snort-3.2.8:
    [1/1] Deleting files for pfSense-pkg-snort-3.2.8….......... done
    Checking integrity... done (0 conflicting)
    Deinstallation has been requested for the following 11 packages:

    Installed packages to be REMOVED:
    broccoli-2.3.2
    barnyard2-1.13
    snort-2.9.7.5
    GeoIP-1.6.6
    daq-2.0.6
    python27-2.7.10
    libdnet-1.12_1
    mysql56-client-5.6.26
    libffi-3.2.1
    libnet-1.1.6_3,1
    luajit-2.0.4

    The operation will free 122 MiB.
    [1/11] Deinstalling snort-2.9.7.5…
    [1/11] Deleting files for snort-2.9.7.5:
    [1/11] Deleting files for snort-2.9.7.5…
    [1/11] Deleting files for snort-2.9.7.5…
    [1/11] Deleting files for snort-2.9.7.5…
    [1/11] Deleting files for snort-2.9.7.5…
    [1/11] Deleting files for snort-2.9.7.5…
    [1/11] Deleting files for snort-2.9.7.5…
    [1/11] Deleting files for snort-2.9.7.5…
    [1/11] Deleting files for snort-2.9.7.5…
    [1/11] Deleting files for snort-2.9.7.5…
    [1/11] Deleting files for snort-2.9.7.5….......... done
    [2/11] Deinstalling barnyard2-1.13…
    [2/11] Deleting files for barnyard2-1.13: ..
    [2/11] Deleting files for barnyard2-1.13…... done
    [3/11] Deinstalling broccoli-2.3.2…
    [3/11] Deleting files for broccoli-2.3.2: …....... done
    [4/11] Deinstalling daq-2.0.6…
    [4/11] Deleting files for daq-2.0.6: …....... done
    [5/11] Deinstalling python27-2.7.10…
    [5/11] Deleting files for python27-2.7.10: …....... done
    [6/11] Deinstalling GeoIP-1.6.6…
    [6/11] Deleting files for GeoIP-1.6.6: …....... done
    [7/11] Deinstalling libdnet-1.12_1…
    [7/11] Deleting files for libdnet-1.12_1: …....... done
    [8/11] Deinstalling mysql56-client-5.6.26…
    [8/11] Deleting files for mysql56-client-5.6.26: …....... done
    [9/11] Deinstalling libffi-3.2.1…
    [9/11] Deleting files for libffi-3.2.1: …....... done
    [10/11] Deinstalling libnet-1.1.6_3,1…
    [10/11] Deleting files for libnet-1.1.6_3,1: …....... done
    [11/11] Deinstalling luajit-2.0.4…
    [11/11] Deleting files for luajit-2.0.4: …....... done
    done.

    Package deleted.

    For not being installed, it seems to have uninstalled a number of items. Also odd that it shows 0 in the universe.
    Is it normal for repeated lines like step 1/11?

    I assume the apparent success of the removal is simply due to the removal script not hitting any errors. I'm just posting this for completeness.


  • Developer Netgate

    The package installation system is a work in progress and that involves basic functionality, not just "wording". I will post here when it is ready for evaluation.

    Some significant changes have taken place in the package system and the GUI is being updated to to accommodate that. This work is actually a separate project but of course it is being done in a Bootstrap-friendly way.



  • Sounds good. I'll hold off on any reporting until further notice (regarding package de/installation).

    Thanks for the quick update.



  • Neither Snort nor Suricata will look good in the GUI (in fact they look awful since they don't have the proper Bootstrap CSS styles).  Also there are likely some other issues with the inclusion of JavaScript and other stuff.  In short, neither package is ready yet for use on pfSense 2.3.  I'm working on converting them to Bootstrap, but it is a slow process since I have some other commitments that are limiting the time I can spend on the packages.

    Bill


Log in to reply