Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/2013122



  • 2.3-ALPHA (amd64)
    built on Sat Oct 10 09:04:28 CDT 2015
    FreeBSD 10.2-STABLE

    login as: root
    Using keyboard-interactive authentication.
    Password for root@bpunk.localdomain:
    
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/suhosin.so' - /usr/local/lib/php/20131226/suhosin.so: Undefined symbol "ps_globals" in Unknown on line 0
    *** Welcome to pfSense 2.3-ALPHA-pfSense (amd64) on bpunk ***
    
     SYM1 (wan)      -> em0        -> v4/DHCP4: 10.0.5.127/18
     LAN (lan)       -> re2        -> v4: 192.168.2.1/24
     SYM2 (opt1)     -> re0        -> v4/DHCP4: 10.0.5.130/18
    
     0) Logout (SSH only)                  9) pfTop
     1) Assign Interfaces                 10) Filter Logs
     2) Set interface(s) IP address       11) Restart webConfigurator
     3) Reset webConfigurator password    12)
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/suhosin.so' - /usr/local/lib/php/20131226/suhosin.so: Undefined symbol "ps_globals" in Unknown on line 0
    pfSense Developer Shell
     4) Reset to factory defaults         13) Upgrade from console
     5) Reboot system                     14) Disable Secure Shell (sshd)
     6) Halt system                       15) Restore recent configuration
     7) Ping host                         16) Restart PHP-FPM
     8) Shell
    
    
    [2.3-ALPHA][root@bpunk.localdomain]/var/log: php -v
    
    Warning: PHP Startup: Unable to load dynamic library '/usr/local/lib/php/20131226/suhosin.so' - /usr/local/lib/php/20131226/suhosin.so: Undefined symbol "ps_globals" in Unknown on line 0
    PHP 5.6.14 (cli) (built: Oct 10 2015 20:27:14)
    Copyright (c) 1997-2015 The PHP Group
    Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
        with Xdebug v2.2.5, Copyright (c) 2002-2014, by Derick Rethans
        with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2015, by Zend Technologies
    [2.3-ALPHA][root@bpunk.localdomain]/var/log:
    
    


  • I just updated and receive the same message on the console.



  • ee /usr/local/etc/php/extensions.ini

    moved the line "extension=suhosin.so" to the end causing it to be the last module to load.  https://forum.pfsense.org/index.php?topic=100883.0



  • Note:
    This may have been obvious to others, but since it wasn't obvious to me right away (and mostly in the case that it helps someone else):

    In order to upgrade via the console, you'll need to follow ariyako's directions and disable the extension.
    Console upgrades failed until I did that and then they worked as normal.

    Cheers.


Log in to reply