Telia Fiber och IPTV



  • Jag försöker hitta en möjlig lösning på att köra Fiber converter > pfSense > LAN med fungerande IPTV från Telia.

    Har försökt att sätta upp en IGMP proxy med följande inställningar:

    LAN ligger på 192.168.1.0/24

    WAN upstream 224.0.0.0/4
    LAN downstream 192.168.1.0/24

    WAN Firewall rules:
    IPv4 IGMP * * 224.0.0.0/4 * * none

    LAN Firewall rules:
    IPv4 * LAN net * * * * none (med “This allows packets with IP options to pass” aktiverat)

    Felet som TV-boxen säger är “unable to start multicast”.

    Gör jag en TCPDUMP på lanet med pfSense så får jag:

    19:04:31.365936 IP gate.hemma > 224.0.0.251: igmp query v2 [gaddr 224.0.0.251]
    19:04:31.366524 IP gate.hemma > all-systems.mcast.net: igmp query v3 [gaddr 224.0.0.251]
    19:06:05.063380 IP 192.168.1.109 > 224.2.2.2: igmp v2 report 224.2.2.2
    19:06:07.520840 IP 192.168.1.109 > 224.2.2.2: igmp v2 report 224.2.2.2

    gate.hemma är pfSense, 192.168.1.109 är tv-boxen.

    Gör jag en TCPDUMP på lanet med Telias Smart switch när det funkar så får jag:

    14:44:07.387357 IP dsldevice.lan > all-systems.mcast.net: igmp query v2 [max resp time 24]
    14:44:08.005044 IP 192.168.1.72 > 239.16.16.202: igmp v2 report 239.16.16.202

    dsldevice.lan  är Telia Smart, 192.168.1.72 är tv-boxen.

    Jag skall erkänna att jag famlar en smula i mörkret. Alla tips är välkomna!



  • Läs “IPTV från banhof genom pfsense”  jag har gett lösningen där. Det gäller att du kan avvara en separat ethernet port för iptv boxen. Sen kan du slänga Telia Smarten åt skogen 😉



  • IPTV boxen vill boota dhcp från telias nät. Så vill du köra den genom egen dhcp server måste du lura den genom att konfa din dhcp server med relay osv. Rätt drygt så smidigaste sättet är att brygga en spec nätverkport till iptv vlan’et.

    Bridge_VLAN845  {WAN.845, ETH1.845}



  • Det löste sig 🙂

    Satte upp ett VLAN internt, sedan bryggade jag VLAN internt med WANets VLAN 845.



  • Gratulerar 🙂



  • Jag är väldigt intresserad av att göra likadant så jag helt kan skippa telias modem/router.
    Du skulle inte kunna tänka dig att göra en liten guide?



  • Kan man fixa så det går att använda “Telia Zappa” appen? Smart funktion men den kräver mer eller mindre att man har Telias icke-så-smarta-router.

    Någon på swec har fixat det med Asus routrar och tomato firmware: http://www.sweclockers.com/forum/trad/1365629-guide-telia-ip-tv-med-valfri-router-ej-bryggat-internt-ip-zappa-fungerar-m-m



  • Halloj alla.

    Jag får inte fart på Telias IPTV.

    Det låter ju så lätt. bara skapa två VLAN och brygga dem. Kirrat. Vad missar jag tro?

    Eller har Telia uppdatarat? Är på en splirrans ny installation av telias nät och min TV-låda verkar vilja ha en IP-adress från thomsonboxen först.
    Sen går den igång. Kanske så det skall vara och bara jag som inte fattar…



  • Så här ser mina fungerande inställningar ut i pfSense.

    Interfaces:
    WAN - Port 1 fiberconverter
    WAN_IPTV - Port 3 på fiberconverter
    LAN
    LAN_IPTV (vlan 845 på LAN)

    Bridge:
    WAN_IPTV, LAN_IPTV

    Vlan:
    Interface VLAN tag
    re1 (lan) 845

    Firewall:
    WAN_IPTV
    Allow IPV4 UDP 224.0.0.0/4

    LAN_IPTV
    Allow IPV4 IGMP 224.0.0.0/4

    System > Advanced > System tunables
    net.link.bridge.pfil_bridge till 0

    Sedan så har jag switchar i lanet som hanterar att ta emot VLAN 845 till otaggat på de portar där jag har tv-boxarna.



  • Tack för infon Peaksie.

    Nu har jag försök få till det. Jag har ingen fiber in utan allt kommer på en TP-kabel redan. Med andra ord så får jag köra både WAN och WAN_IPTV på samma fysiska interface.
    Jag tycker jag matchat din fins guide till fullo. Jag tog skärmdumpar på alla inställningarna. Får se hur snabbt nån påpekar att jag missat nått eller gjort nått fel. 😛

    Längst ned på finns portconfiggen på min Netgear GS116Ev2 - 16-Port Gigabit ProSAFE  switch. Den kanske är för enkel?
    Port 16 sitter PFSensen på, Port 7 sitter Telias kabelbox på. (En Arris VIP1113L).
    VLAN 1 finns otaggat på alla portar.

    Inte satt nån prioritet på VLAN’en. Det måste kanske också matcha?

    Edit: Kan ju tillägga att boxen får IP-adress men ger felmeddelandet: Systemet får ingen multicast. (Felkod: 712)

    Inställningarna:



  • Jag kör telia iptv via fiber.
    Telia meddelade att vlan245 skulle det vara. Fick aldrig det att funka. När jag bytte till 845 så fick jag till det 😃

    OPT4 porten på min SG-4860 är den jag confat för tv boxen vlan 845.
    Jag har satt samtliga interface: IPv4 Configuration Type = None


















  • @peaksie:

    Så här ser mina fungerande inställningar ut i pfSense.

    Interfaces:
    WAN - Port 1 fiberconverter
    WAN_IPTV - Port 3 på fiberconverter
    LAN
    LAN_IPTV (vlan 845 på LAN)

    Bridge:
    WAN_IPTV, LAN_IPTV

    Vlan:
    Interface VLAN tag
    re1 (lan) 845

    Firewall:
    WAN_IPTV
    Allow IPV4 UDP 224.0.0.0/4

    LAN_IPTV
    Allow IPV4 IGMP 224.0.0.0/4

    System > Advanced > System tunables
    net.link.bridge.pfil_bridge till 0

    Sedan så har jag switchar i lanet som hanterar att ta emot VLAN 845 till otaggat på de portar där jag har tv-boxarna.

    Har du 4 portar på din pfSense box?



  • En nybörjarfråga - kör ni IPTV-signalen på samma nät som LANet, dvs ser det nätet ut enligt nedan eller har ni dragit en separat fysisk kabel från pfSense VLAN-port till TV:n?

    +–--------------------+                ±-------------+              ±-------------+
        |                      ±—WLAN------->|              |              |              |
        |  Fiber Converter    |                |              -----LAN-------->              |
        |                      ±—WAN-IPTV—>|              |              |              |
        ±---------------------+                |  pfSense      ----VLAN-IPTV–>  Switch    |
                                                |              |              |              |
                                                |              |              |              |
                                                |              |              |              |
                                                |              |              |              |
                                                ±-------------+              ±-------------+



  • Hade lite problem med detta så jag tänkte bidra med min konf…
    Så här ser mitt nätverk ut till att börja med.

    +–--------------------+              ±-------------+              ±-------------+
        |                      ±—WAN------->|              |              |              |
        |  Fiber Converter    |              |              ±—LAN-------->              ±-NAS (VPN/LAN)
        |                      |              |              |    VLAN-IPTV  |              |
        ±---------------------+              |  pfSense    |    VLAN-VPN  |    Switch    ±-Telia TV-Box (IP-TV)
                                              |              |              |              |
                                              |              |              |              ±-TV/Recieiver (LAN)
                                              |              |              |              |
                                              |              ±–<ap>        |              |
                                              ±-------------+              ±-------------+

    VLAN:
    Interface      VLAN tag
    em0 (WAN)  845
    em1 (LAN)  845

    Interface:
    WAN - Port 1 fiberconverter
    WAN_IPTV  (vlan 845 på WAN)
    LAN_IPTV (vlan 845 på LAN)

    Bridge:
    WAN_IPTV, LAN_IPTV

    Inga brandväggsregler behövs för bryggan eftersom

    System > Advanced > System tunables
    net.link.bridge.pfil_bridge = 0
    net.link.bridge.pfil_member = 0
    (Detta är ingen säkerhetsrisk eftersom dessa inställningar endast påverkar bryggan)

    Switchen som jag använder är en Netgear GS105 Den är konfad på följande sätt:

    Tagged VLAN 1, 845 = Port 0 (Kabel in till Switch)
    Untagged VLAN 845 = Port 4 (Till TV-box)

    IGMP Snooping = Enable
    VLAN ID Enabled for IGMP Snooping = 845
    IGMP Snooping Static Router Port =01

    Allting såg ut stämma men det funkade ändå inte… Efter några timmars felsökning hittade jag orsaken. Anledningen var att jag hade annan brygga (LAN+AP_LAN) uppsatt som delade interface (em1) med den nya bryggan skapad för IP-TVn. Fick inga felmeddelanden i pfsense utan det funkade inte bara >:(. Blir tydligen problem när man blandar interface och bryggor…
    Så lösningen var att se till att endast en brygga fanns på det fysiska interfacet. När jag gjorde det så funkade allt klockrent  8).</ap>



  • @Dalsland:

    Switchen som jag använder är en Netgear GS105 Den är konfad på följande sätt…

    Är inte Netgear GS105 en omanagerad switch?



  • Hej,

    jag har konfigurerat pfSense för VLAN 845 passthrough enligt Dalslands post. Problemet är att ljudet är väldigt hackigt och jag får ingen bild… Tv-boxen klagar på att “Tjänsten är inte tillgänglig” men kommer förbi “Välkommen till Telia…” och fram till själva tv bilden men med ovan nämda problem. Detta händer när jag har WAN direkt till pfSense och en switch (netgear GS108Ev3) på LAN sidan med VLAN 845 till tv-boxen. Sätter jag switchen före pfSense funkar det utan problem, så switch konfiguren verkar vara ok.

    Något verkar alltså vara tok med pfSense konfigen. Har som sagt följt Dalslands konf till punkt och pricka och har för övrigt inget speciellt i pfSense (squid proxy + squidguard men de är ju konfade på LAN interfacet)

    Har satt följande
    System > Advanced > System tunables
    net.link.bridge.pfil_bridge = 0
    net.link.bridge.pfil_member = 0

    Men har även lagt till firewall regler som tillåter allt genom WAN_IPTV och LAN_IPTV… men utan framgång

    Någon som har en ide vad felet kan bero på eller förslag på felsökning? Tacksam för hjälp!!!

    4_1528575023519_interface.png 3_1528575023518_vlan.png 2_1528575023518_bridge.png 1_1528575023518_firefall1.png 0_1528575023517_firefall2.png


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy