Error in LightSquid after 2.42 update



  • Hello Sirs,

    Updated Lightsquid on a machine running pfSense v2.0.3 amd64 and now I get:

    "Parse error: syntax error, unexpected ':' in /usr/local/pkg/lightsquid.inc on line 455"  when trying to access lightsquid from the webgui menu.

    Updated same package on a machine running pfSense v2.1.4 i386 and everything is ok.

    Searched the forums and google, but came up empty.  Lightsquid worked previously on both machines above.

    Your help is very much appreciated. :)


  • Banned

    You are welcome to patch it yourself for unsupported pfSense versions running dead PHP version that doesn't support such syntax.

    
    $ext_cachemanager = ($config['installedpackages']['squidnac']['config'][0]['ext_cachemanager'] ? $config['installedpackages']['squidnac']['config'][0]['ext_cachemanager'] : "");
    
    

    Upgrade your pfSense!!!



  • Very well then… Will look into upgrading the pf version on it.

    The machine has been working fine for ages now, so I am really hesitant to touch anything I don't know about in there.  :P



  • @josekym:

    Very well then… Will look into upgrading the pf version on it.

    The machine has been working fine for ages now, so I am really hesitant to touch anything I don't know about in there.  :P

    Then spin up a VM in VirtualBox or VMware Workstation and test it out first… 2.2.4 has been stable for a while now, everyone's busy getting 2.3 ready

    try out different scenarios, install the same version and import your configs then upgrade to 2.2.4 and see what happens. OR roll from scratch, reinstall all your packages you currently use and reconfigure.

    As long as you test it first, and don't go upgrading your production system without a plan



  • Thanks for your help, you guys!

    Managed to upgrade all our pfSense boxes to 2.2.4 now, thanks to the info on these here forums.

    Now running the latest Squid and SG, and so far all are working as before… :)


Log in to reply