Installation via Physdisk langsamer als USB?



  • Hallo!

    Nutze eine APU 1C samt 2.2.4 die mir gestern gecrasht ist und danach bei F1 boot hängen blieb. Da ich die Box schnell wieder brauchte, habe ich das Image komplett neu auf die SD Karte via Physdisk neu aufgespielt und installiert. Nun stelle ich fest, dass vor allem Schreibzugriffe deutlich langsamer sind als die Installation zu vor via USB. Ist das möglich und wieso?

    Danke.



  • Das ist schon möglich.
    Kommt drauf an was du für eine SD Karte hast?
    SDHC 10 oder was anderes?
    Kommt auch manchmal auf die Marke an.
    Vielleicht ist der USB Stick einfach besser/schneller gewesen als die SD Karte jetzt.



  • Es geht lediglich um die Installation. Auch die davor lief auf der gleichen SD Karte (Class 10 SanDisk). Ich hatte nur vom USB Stick aus installiert und nun die SD Karte direkt beschrieben, ohne Installationsroutine sozusagen.



  • ach so wenn du das von Windows aus machst dauert das recht lange das stimmt.
    Der schreibt ja wirklich 4 GB auf die Karte wenn du das 4 Gb Image nimmst. Das kann je nach Karte und Kartenleser schon etwas dauern.



  • Also ich bin mir immer noch nicht ganz sicher was du meinst:

    Ist nur der Installationsprozess langsamer gewesen, oder ist jetzt nach der Installation der Betrieb langsamer?

    gruß



  • Der Betrieb war langsam. Ein Package zu installieren dauerte teils 5 Minuten. Habe nun wieder via USB installiert und das gleiche Package ist in wenigen Sekunden installiert und alles ist wieder normal schnell.



  • Ich weiß nicht wie das bei dem Linux unter der Sense ist.

    Bei Windows kann es passieren, dass die Cluster vom OS ungünstig und unpassend zu den Clustern auf einer SSD erzeugt werden. Dann werden Schreibzugriffe auf die SSD erheblich langsamer, weil unnötig immer auf zwei Cluster zugegriffen werden muss, auch wenn das OS eigentlich nur einen Cluster anfassen wollte.

    Vielleicht ist das da etwas vergleichbares. Wenn du das Image zurückschreibst, dann könnte es passieren, dass die Partition um einen Betrag versetzt geschrieben wird. Das würde funktionieren, aber erheblich langsamer. Wenn du über die Sense selber die SSD formatierst/partitionierst, dann sollte das immer richtig sein.


  • Rebel Alliance Moderator

    Ich weiß nicht wie das bei dem Linux unter der Sense ist.
    Das ist ein FreeBSD mit UFS, kein Ext3/4 oder ähnliches.

    Habe nun wieder via USB installiert und das gleiche Package ist in wenigen Sekunden installiert und alles ist wieder normal schnell.
    Hast du die SD Karte jetzt mit einer NanoBSD Installation bestückt oder eine Vollinstallation auf die SD Karte gemacht? Das ist mitunter schon ein ziemlicher Unterschied. Wir hatten auch Geräte und SD Karten hier, die mit NanoBSD auf SD flott liefen, andere hatten Probleme, dass beim mount_ro jedes Mal ewig gewartet wurde (weshalb ist unklar). Aber jedes Mal beim Wechseln von ro->rw->ro gab es große Wartezeiten.

    Grüße



  • Ich habe wieder ein Vollimage installiert, hatte aber auch schonmal ein nano auf SD welches flott lief.


Log in to reply