PfSense OpenVPN Client



  • Hey Guys!

    I asked about this in the IRC Chat, so if you helped me there, thanks a ton for the help, but I still cannot connect. On to the issue at hand.

    I have pfSense installed in a VM on a Debian Linux box. This Debian Linux box can connect to my OpenVPN Server just fine. pfSense on the other hand, cannot. I keep getting a "P_CONTROL_HARD_RESET_CLIENT_V2" message (the server gets the same message, but SERVER instead of CLIENT)m and it never connects. The VM interface for pfSense is a bridged interface.

    I have tried 2 ways to get the config and certs onto pfSense:
    1. Using the WebUI and matching as closely as I can.
    2. Transfer the files themselves.

    I obviously tried the WebUI method first. But given that the same error message appears either way, I doubt that the problem is solely to do with the configuration.

    Here's what gets me… The EXACT SAME .ovpn files, certs, and connectivity (routes, next-hop, etc...) are the same for the Debian Linux host, and the VM. The host can connect just fine, no problems, and the VM gets a "P_CONTROL_HARD_RESET_CLIENT_V2" error of some kind.

    With the help of some of the guys on the IRC chat, we went through just about every option on the WebUI config. They also gave me the idea to use the same files the Debian host is using, and just calling openvpn from the CLI with the --config option. So the exact same config and certs are giving me 1 perfect connection, and 1 that cannot connect at all.

    This same VPN is fully useable by my Debian Linux host, my phone, and a number of other random devices not part of this project. So I know that the server side of things is (reasonably) properly configured.

    What is going on? Whare/what can I check to further figure this out? I am completely stumped on how to get this to connect...


Log in to reply