Squid3 with MITM issue on Firefox



  • Hello,

    I have installed squid3 and configured MITM with my internal CA certificate and everything is working fine on IE and Chrome but on Firefox i got the below error when i am trying to access any HTTPS website.

    An error occurred during a connection to www.yahoo.com.

    SSL received a record that exceeded the maximum permissible length.

    (Error code: ssl_error_rx_record_too_long)

    Please note I configured transparent proxy with WPAD on DNS.

    Can anyone help me to solve this issue?

    BR,
    Ahmed



  • In firefox, you have to manually add the certificate.

    Firefox –->options-->advanced-->certificate-->view certificates -->authorities-->add



  • I tried this solution but doesn't work.

    I found the proxy setting on the Firefox configured on use system proxy not auto detect the proxy setting from this network after I chosed it the internet working fine on Firefox.

    Thank for your help exograpix.



  • Make sure when you import your cert to Firefox that the "Authorities" tab selected.  It works.


Log in to reply