Problema de Redirección Portal Cautivo



  • Muy buenas a todos

    tengo el siguiente problema….

    Los usuarios no están siendo redireccionados al portal cuando digitan X sitio Web, por ejemplo
    Al momento de abrir el navegador (en este caso chrome)

    Usuario escribe > www.gmail.com > no redirecciona a la pagina de autentificación del portal
    Usuario escribe > www.facebook.com > no redirecciona a la pagina de autentificación del portal

    en ambos casos y otros sitios webs, solo se queda "pensando" y al final tira un error de que no hay conexión.

    Usuario escribe > www.google.cl o .com > redirreciona de inmediato a la pagina de autentificación del portal
    Usuario escribe > www.youtube.com > redirreciona de inmediato a la pagina de autentificación del portal

    he buscando alguna opción probable y nada
    cualquier ayuda es bienvenida, muchas gracias por todo
    saludos



  • https://doc.pfsense.org/index.php/Captive_Portal_Troubleshooting#Captive_portal_not_redirecting

    Ahí tenés las explicaciones (buscan sitios https) de por qué no redirecciona.

    También tenés tips para hacer que el redireccionamiento funcione

    Abz



  • gracias por responder, pero es bastante raro
    ya que google es https y redirecciona bien
    pero paginas como youtube o gmail no lo hace, además siendo de la misma empresa.

    Estoy "experimentando" habilitando el DNS Resolver, deshabilite DNS Forwarder y aún así no lo hace, tiene el mismo efecto que el anterior.
    Seguire con el DNS Server ( TinyDNS) aún no lo pruebo pero veremos que pasa ;)

    saludos



  • Trata 1ro en tu equipo de pruebas, pero antes de borra todo el cache, temporales etc como con ccleaner e intentas, a ver si te sirve de algo, saludos.



  • no es un problema de cliente
    es del servidor, ya que he intentado con más de 5 equipos y pasa lo mismo en todos por igual.

    saludos



  • Era una sugerencia solamente animo.



  • si se, gracias por la ayuda y el tiempo de hacerlo ;)



  • Me parece que como hay paginas que están tanto en http como en https (youtube), por esta razón abren la pagina del portal. no se si facebook esta solo en https y por eso no abre.



  • @Darevas:

    gracias por responder, pero es bastante raro
    ya que google es https y redirecciona bien
    pero paginas como youtube o gmail no lo hace, además siendo de la misma empresa.

    Como te han dicho, Google puede iniciarse en modo http y después cambia a https

    Y hay servicios que se inician siempre en modo https

    Esto es así porque la obligación de https en las búsquedas de Google es de implantación reciente para la privacidad al usuario logueado en su cuenta Google.

    Since 2011, google automatically redirect logged-in users to the https search site and this defeats the filters.

    http://linuxcentre.net/wiki/index.php/Web_Content_Filtering#The_Google_SSL_Search_problem_and_Google_Apps_for_Education


Log in to reply