DNS Auflösung über OpenVPN



  • Hallo zusammen!

    Lokal im Netz kann ich jeden Client über seine IP (10.0.0.x) und seinen Host Namen (z.B. NAS.homenet.lan) erreicht. Verbinde ich mich mit dem iPad/iPhone von außen via OpenVPN funktioniert nur die IP Adressen - mit den Host Namen funktioniert es nicht. Ich habe auch schon versucht unter <openvpn: server=""><dns server="">die IP der pfSense (10.0.0.1) einzutragen - leider hat das nichts gebracht. Wo liegt der Fehler?

    Danke vorab.

    LG
    Thomas</dns></openvpn:>


  • Rebel Alliance Moderator

    Hast du auf dem Client nachgesehen, ob der den DNS Server gepusht bekommt und diesen auch erreichen kann bzw. ob eine Abfrage funktioniert?



  • Am Client (iPhone) zeigen sich folgende Logs:

    2015-10-27 22:27:23 SSL Handshake: TLSv1.2/TLS-DHE-RSA-WITH-AES-256-CBC-SHA
    2015-10-27 22:27:23 Session is ACTIVE
    2015-10-27 22:27:23 EVENT: GET_CONFIG
    2015-10-27 22:27:23 Sending PUSH_REQUEST to server...
    2015-10-27 22:27:23 OPTIONS:
    0 [route] [10.0.0.0] [255.255.255.0] 
    1 [dhcp-option] [DOMAIN] [10.0.9.1] 
    2 [dhcp-option] [DNS] [10.0.0.1] 
    3 [route] [10.0.9.0] [255.255.255.0] 
    4 [topology] [net30] 
    5 [ping] [10] 
    6 [ping-restart] [60] 
    7 [ifconfig] [10.0.9.6] [10.0.9.5] 
    
    2015-10-27 22:27:23 LZO-ASYM init swap=0 asym=0
    2015-10-27 22:27:23 EVENT: ASSIGN_IP
    2015-10-27 22:27:23 Connected via tun
    

    LG
    Thomas


  • Rebel Alliance Moderator

    Das mag sein :) Aber kann das iPhone etwas mit 10.0.0.1 anfangen? Kann es den Server erreichen/pingen? Klappt ein DNS Aufruf von dort? Gibt ja vielleicht eine Netzwerk-Tools-App mit der man das testen kann? :)



  • 10.0.0.1 kann ich mit dem iPhone (wie alle anderen Clients im NW) anpingen. Die pfSense erreiche ich über PFS.homenet.lan nicht.

    LG
    Thomas


  • Rebel Alliance Moderator

    Pingen ist schonmal gut, aber ggf. ist der DNS nicht erlaubt? Also entweder per Regel nicht erlaubt oder du hast vielleicht den DNS Resolver/Forwarder nicht auf alle Interfaces hören lassen? Dass der nicht aufs VPN Interface gebunden hört?



  • Als Regel habe ich folgendes eingestellt:

    Action: Pass
    Interface: OpenVPN
    TCP/IP Version: IPv4
    Source: any
    Destination: any

    Ich denke, hier liegt das Problem nicht.

    Bei DNS forwarder habe ich die Interfaces 'LAN', 'OPT2' und 'Localhost' aktiviert (siehe Anhang).

    Das Service DNS Resolver ist nicht aktiviert.

    LG
    Thomas



  • Rebel Alliance Moderator

    Kannst du das Forwarder Interface mal spaßeshalber auf ALL stellen und ihn neustarten ob er es dann macht?



  • Hat leider nichts gebracht!


Log in to reply