Problem with vmware tools in vSphere 6.0 U1 - pfsense 2.2.4



  • Hi,

    First of all I thought that vmware tools provided from vmware would work on my pfsense installation but since I read that it is better to go with open-vm-tools package I first tried that.

    The problem seems to be that it is not correctly installing, I followed this link:

    https://doc.pfsense.org/index.php/Open_VM_Tools_package

    to check if the package installed correctly but I am getting the following results (after rebooting the pfsense VM)

    ps uxawww | grep vmware

    $ ps uxawww | grep vmware
    root    55945  0.0  0.4 101052  8212  -  S     2:33PM  0:00.17 /usr/local/bin/vmtoolsd -c /usr/pbi/open-vm-tools-amd64/local/share/vmware-tools/tools.conf -p /usr/pbi/open-vm-tools-amd64/local/lib/open-vm-tools/plugins/vmsvc
    root    61880  0.0  0.1  17136  2644  -  S     2:46PM  0:00.00 sh -c ps uxawww | grep vmware 2>&1
    root    62272  0.0  0.0    544   456  -  R     2:46PM  0:00.00 grep vmware
    

    kldstat

    $ kldstat
    Id Refs Address            Size     Name
     1    1 0xffffffff80200000 22d8418  kernel
    

    So it seems something is wrong leading me to the first question.

    1. Is open-vm-tools still not supported in pfsense 2.2.4 with vSphere 6.0 U1? (I am using E1000 network interface type)

    Also I would like to ask 2 more questions please.

    2. Is it still recommended to use the open-vm-tools package over the native vmware tools?

    3. Should I use VMXNET3 in my current configuration? or still go with E1000 which I chose as default when creating the VM?



  • Since pfSense 2.2, you don't need to install those vmx drivers since they come baked into FreeBSD 10.  You can use vmxnet3 NICs right out of the box without having to install anything else.



  • you need to change your NIC to vmxnet3 it works out of the box.
    I just update to the latest pfsense 2.2.5 and using latest VMware patchs , everything works fine



  • I've got the same exact problem.  I updated to the latest esxi 6.0 u1.  I never had the vmware tools installed, so I figured I would try them.  After installing the open vm tools, I see that the /usr/local/bin/vmtoolsd is running, but nothing is showing in kldstat, like the wiki page has.

    I mean, the networking cards do work just fine, but I wonder if there's better "optimizations" after installing the vmware tools.

    So, OP, you're not alone because I have the same exact problem….but again, all the NIC's work just fine.

    EDIT: You mentioned you're using 2.2.4.  I'm on 2.2.5 and still having the problem.



  • It's not supposed to show anything in kldstat. The vmxnet driver is built in. The other kernel modules aren't all that useful and some of them cause stability issues. If vmware-guestd is running, open-vm-tools is fine.


Log in to reply